2.0.15 won't link via radio


I’ve tried using 2.0.15 on my MacBook Pro.
2.0.14 works perfectly.
Using 3DR radio v2.

2.0.15 refuses to connect via radio (USB works) it simply hangs the application.
Checked settings etc. but now stumped!

Open 2.0.14 and all works…

Any thoughts? Anyone!

Many thanks

Hi, have you managed to resolve this issue?

can you post ~/apmplanner2/logs.txt after you have tried to connect (you may need to compress the file to attache aka zip it)


I have the same problem. I think APM Planner is confused by the node ID number that precedes every output line. That’s not present in v1.9. Here’s the log output:

[size=85]DEBUG 2015-03-06T16:21:30.750 MODE: 0
DEBUG 2015-03-06T16:21:30.750 "D|PREFLIGHT"
DEBUG 2015-03-06T16:21:30.750 MODE: 80
DEBUG 2015-03-06T16:21:30.750 "D|STABILIZED"
DEBUG 2015-03-06T16:21:30.750 MODE: 64
DEBUG 2015-03-06T16:21:30.751 "D|MANUAL"
DEBUG 2015-03-06T16:21:30.751 MODE: 88
DEBUG 2015-03-06T16:21:30.751 "D|VECTOR|STABILIZED"
DEBUG 2015-03-06T16:21:30.751 MODE: 92
DEBUG 2015-03-06T16:21:30.751 "D|AUTO|STABILIZED"
DEBUG 2015-03-06T16:21:30.751 MODE: 66
DEBUG 2015-03-06T16:21:30.751 "D|TEST"
DEBUG 2015-03-06T16:21:30.783 QUrl( “file:///Applications/APM Planner 2.0.app/Contents/MacOS/qml/PrimaryFlightDisplayQML.qml” )
DEBUG 2015-03-06T16:21:31.846 QML Status: 1
DEBUG 2015-03-06T16:21:31.847 QUrl( “file:///Applications/APM Planner 2.0.app/Contents/MacOS/qml/PrimaryFlightDisplayQML.qml” )
DEBUG 2015-03-06T16:21:31.881 QML Status: 1
INFO 2015-03-06T16:21:31.886 UASActionsWidget creating UASActionsWidget(0x10fd570c0)
DEBUG 2015-03-06T16:21:31.888 QuickView: load settings
DEBUG 2015-03-06T16:21:31.888 QuickView: loading key: “GCS Status.Altitude (GPS) (m)” type: "text"
DEBUG 2015-03-06T16:21:31.890 QuickView: loading key: “GCS Status.Altitude (REL) (m)” type: "text"
DEBUG 2015-03-06T16:21:31.891 QuickView: loading key: “GCS Status.Battery (%)” type: "text"
DEBUG 2015-03-06T16:21:31.893 QuickView: loading key: “GCS Status.Climb (m/s)” type: "text"
DEBUG 2015-03-06T16:21:31.895 QuickView: loading key: “GCS Status.Current (A)” type: "text"
DEBUG 2015-03-06T16:21:31.897 QuickView: loading key: “GCS Status.GPS Fix ()” type: "text"
DEBUG 2015-03-06T16:21:31.900 QuickView: loading key: “GCS Status.GPS HDOP (m)” type: "text"
DEBUG 2015-03-06T16:21:31.902 QuickView: loading key: “GCS Status.GPS Sats ()” type: "text"
DEBUG 2015-03-06T16:21:31.905 QuickView: loading key: “GCS Status.Pitch (deg)” type: "text"
DEBUG 2015-03-06T16:21:31.907 QuickView: loading key: “GCS Status.Roll (deg)” type: "text"
DEBUG 2015-03-06T16:21:31.910 QuickView: loading key: “GCS Status.Voltage (V)” type: "text"
DEBUG 2015-03-06T16:21:31.913 QuickView: loading key: “GCS Status.Yaw (deg)” type: "text"
DEBUG 2015-03-06T16:21:31.918 QuickView: load settings END
DEBUG 2015-03-06T16:21:31.971 qmlBaseDir "/Applications/APM Planner 2.0.app/Contents/MacOS"
DEBUG 2015-03-06T16:21:31.971 QUrl( “file:///Applications/APM Planner 2.0.app/Contents/MacOS/qml/ApmToolBar.qml” )
DEBUG 2015-03-06T16:21:31.997 QML Status: 1
DEBUG 2015-03-06T16:21:32.001 Loading widget: "PRIMARY_FLIGHT_DISPLAY_QML_DOCKWIDGET"
DEBUG 2015-03-06T16:21:32.001 Loading widget: "UAS_INFO_INFOVIEW_DOCKWIDGET"
INFO 2015-03-06T16:21:33.381 “Bluetooth-Incoming-Port” 115200
DEBUG 2015-03-06T16:21:33.384 APMToolBar: new Serial Link Created 1
DEBUG 2015-03-06T16:21:33.384 APMToolBar setConnection: false
DEBUG 2015-03-06T16:21:33.385 APMToolBar: updateLinkDisplay “” 115200 false
INFO 2015-03-06T16:21:33.386 UDP Created "UDP Link (port:14550)"
INFO 2015-03-06T16:21:33.387 UDP disconnect
INFO 2015-03-06T16:21:33.387 UDPLink::UDP connect QHostAddress( “” ) : 14550
ERROR 2015-03-06T16:21:33.387 bind failed! QHostAddress( “” ) : 14550
DEBUG 2015-03-06T16:21:33.400 SCW: Link is disconnected
DEBUG 2015-03-06T16:21:33.402 Baud rate: 115200 Expected: 4
DEBUG 2015-03-06T16:21:37.870 "retrieve versionobject from server: firmware.diydrones.com/Tools/APM … rsion.json"
DEBUG 2015-03-06T16:21:38.169 Downloading: 1147 / 4156
DEBUG 2015-03-06T16:21:38.171 Downloading: 4156 / 4156
DEBUG 2015-03-06T16:21:38.172 AutoUpdateCheck::httpFinished()
DEBUG 2015-03-06T16:21:38.193 Detected newVersion: (“2.0.15”, “2.0.15”, “”) count: 2
DEBUG 2015-03-06T16:21:38.193 Detected currentVersion: (“2.0.15”, “2.0.15”, “”) count: 2
DEBUG 2015-03-06T16:21:38.193 Verison Compare: " New Version 2.0.15 compared to Old Version 2.0.15"
INFO 2015-03-06T16:21:38.193 no new update available
DEBUG 2015-03-06T16:21:41.489 3DR Radio Start Serial Port Scanning
INFO 2015-03-06T16:21:47.557 read 3DR Radio Settings
DEBUG 2015-03-06T16:21:47.562 Radio3DRSettings Serial Port Open SUCCESS "usbserial-DN006VFG"
DEBUG 2015-03-06T16:21:47.562 Port “usbserial-DN006VFG” 115200 8 FC 0 P 0 SB 1
INFO 2015-03-06T16:21:47.563 Port Configured with success
DEBUG 2015-03-06T16:21:47.563 Radio3DRSettings::writeEscapeSeqeunce()
DEBUG 2015-03-06T16:21:47.563 local status: "entering command mode"
INFO 2015-03-06T16:21:47.563 Retry 1
DEBUG 2015-03-06T16:21:48.641 Radio3DRSettings::writeEscapeSeqeunceNow()
DEBUG 2015-03-06T16:21:49.641 Radio readData currentline: "[0] OK
INFO 2015-03-06T16:21:49.642 3DR Radio: Entered Command Mode
DEBUG 2015-03-06T16:21:49.642 local status: "Entered Command mode"
DEBUG 2015-03-06T16:21:49.642 Radio3DRSettings::readLocalVersionString()
DEBUG 2015-03-06T16:21:49.642 local status: "Read local radio version"
DEBUG 2015-03-06T16:21:49.660 Radio readData currentline: "ATI0
DEBUG 2015-03-06T16:21:49.660 Radio readData nextline: “[0] MP SiK 2.3 on RFD900A
” [/size]

It hasn’t been tested with Sik2.3. It could indeed break the code. I’ll need to see if I can install 2.3 on a 3dr radio