2.0.14 install issue

Just did a complete git clone last night to build the latest 2.0.14 - 2014-08-01 on my Raspberry Pi. All went well, the build worked fine,

The “sudo make install” didn’t set something correctly.

From /home/pi , when I run “/bin/apmplanner2” it errors with:
/home/pi/qml/PrimaryFlightDisplayQML.qml not found. Please reinstall the application and try again.

If I go to the release directory and run ./apmplanner2 then it starts up and runs without an error.
If I go to the release directory and run /bin/apmplanner2 then it starts up and runs without an error.

Its because the file is in /bin/apmplanner2/qml/PrimaryFlightDisplayQML.qml

The simplest workaround is to write a script that cd to that directory before executing the exec

#! /bin/bash
cd /bin/apmplanner2
./apmplanner &

or something like that.



Afraid that won’t work. BTW, the error message I quoted is from the popup window.

pi@raspberrypi ~ $ cd /bin
pi@raspberrypi /bin $ ls
[size=85][size=50]apmplanner2 bzless dd fgconsole kill lsmod nc ps sh.distrib umount zforce
bash bzmore df fgrep kmod mkdir nc.openbsd pwd sleep uname zgrep
bunzip2 cat dir findmnt less mknod nc.traditional rbash ss uncompress zless
bzcat chgrp dmesg fuser lessecho mktemp netcat readlink stty unicode_start zmore
bzcmp chmod dnsdomainname fusermount lessfile modeline2fb netstat rm su vdir znew
bzdiff chown domainname grep lesskey more nisdomainname rmdir sync which
bzegrep chvt dumpkeys gunzip lesspipe mount open rnano tailf ypdomainname
bzexe con2fbmap echo gzexe ln mountpoint openvt run-parts tar zcat
bzfgrep cp ed gzip loadkeys mt pidof sed tempfile zcmp
bzgrep cpio egrep hostname login mt-gnu ping setfont touch zdiff
bzip2 dash false ip ls mv ping6 setupcon true zegrep
bzip2recover date fbset kbd_mode lsblk nano plymouth sh ulockmgr_server zfgrep[/size][/size]
pi@raspberrypi /bin $ file apmplanner2
apmplanner2: ELF 32-bit LSB executable, ARM, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.26, BuildID[sha1]=0x03c68067a6a5f1794e3aed6518bd65a19de4237c, stripped
pi@raspberrypi /bin $

The “sudo make install” placed the file in:

I can do this until the next release:

#! /bin/bash
cd $HOME/apmplanner2/apm_planner/release
./apmplanner &