WAF Configuration Still Fails

I am a C-Matlab programmer, no Python.
I am trying to build for Rover 4.
I am using Windows 10, and the cygwin installation as described in Ardupilot for WAF/Eclipse.
I just installed Python 3.8 and cygwin as per Ardupilot instructions

When I run $ ./waf configure --board CubeBlack I get:
Setting top to : C:\cygwin64\home\Dave\Ardupilot
Setting out to : C:\cygwin64\home\Dave\Ardupilot\build
Autoconfiguration : enabled
Setting board to : CubeBlack
Using toolchain : arm-none-eabi
Checking for ‘g++’ (C++ compiler) : C:\Program Files (x86)\GNU Tools ARM Embedded\6 2017-q2-update\bin\arm-none-eabi-g++.exe
Checking for ‘gcc’ (C compiler) : C:\Program Files (x86)\GNU Tools ARM Embedded\6 2017-q2-update\bin\arm-none-eabi-gcc.exe
Checking for c flags ‘-MMD’ :
Checking for cxx flags ‘-MMD’ :
Checking for program ‘make’ : C:\cygwin64\bin\make.exe
Checking for program ‘arm-none-eabi-objcopy’ : C:\Program Files (x86)\GNU Tools ARM Embedded\6 2017-q2-update\bin\arm-none-eabi-objcopy.exe
“”""""""""" Here’s the error""""""""""""""""""""
C:\Users\E6330\AppData\Local\Programs\Python\Python37\python.exe: can’t open file ‘‘C:\cygwin64\home\Dave\Ardupilot\libraries/AP_HAL_ChibiOS/hwdef/scripts/chibios_hwdef.py’’: [Errno 22] Invalid argument
Failed to process hwdef.dat ret=2
(complete log in C:\cygwin64\home\Dave\Ardupilot\build\config.log)

If I run the first part of this failed command in cygwin I get:
Dave@Laptop ~/Ardupilot
$ C:\Users\E6330\AppData\Local\Programs\Python\Python37\python.exe
-bash: C:UsersE6330AppDataLocalProgramsPythonPython37python.exe: command not found
i.e. It fails

If I flip all of the \ to / it runs:
$ C:/Users/E6330/AppData/Local/Programs/Python/Python37/python.exe
Python 3.7.7 (tags/v3.7.7:d7c567b08f, Mar 10 2020, 10:41:24) [MSC v.1900 64 bit (AMD64)] on win32
Type “help”, “copyright”, “credits” or “license” for more information.

Does anyone know what is going on here? Wrong Python version? If so can I just uninstall 3.8 and install a down rev version like 2.7 or do I need to install Python before cygwin?

Also, is there a better place to post a question like this?


It’s an issue with Python not being properly configured in your environment. See Build problem in cygwin: /usr/bin/env: ‘python’ for a similar issue (and fix)

1 Like

Good day, just i case you can try compile the firmware using Ubuntu under Windows 10 environment… fast and easy for update the git