Vibe good but clip2 high

High I am seeing an issue on my copter build (quad - 3200 grams) The issue is the vibe remains below 30 the entire flight, but the tertiary clipping increases during flight… though clip 1 and clip2 are 0
I am sure it needs tuning as I used auto-tune and it made it a bit twitchy…, attaching vibe screen log fileclipping capture and todays log… if someone could explain all help is appreciated I don’t know any developers so not sure who to ask for help.
@mboland , any ideas?

It looks like I am having the same problem. In all logs, the VIBE.Clip0 and VIBE.Clip1 are fine at 0. For some reason the VIBE.Clip2 is high and goes all the way to maximum. Does anyone have any idea what could be the cause?

Can you post a log? Which cube are you using?
Also describe or send a picture of how the cube is mounted to the frame… how big is the copter?
Clip to is the tertiary accelorometer…I believe it is un isolated and may be more prone to harmonic vibrations… I replaced 2 black and one blue cube with orange cube… this fixed the clipping (clip2) on all , however after adding the notch on one copter it returned briefly… then after some tuning it disappeared

1 Like

@mbuilds Mike, of course. I am using Cube Black (last year version). I dont know the exact dimensions, it is 500 carbon fibre frame. I have 10-inch holybro motors and props. The flight controller is mounted using double sided tape to the top frame. There are some pictures here in my old post:

And there is another post of mine from a couple of days ago, the very first message has a link to the log:

If you could take a look at it I will be very grateful. Also, do you think this is an issue typical of the Black Cube? I purchased it a year ago, maybe I could claim it for an exchange?

Many thanks!

I don’t think this has anything to do with your vibe clipping issue but are those Mag.MagZ, Mag2.MagZ and Mag3.MagZ ok? Looks like they jump around, esp Mag2

@nn72 I wish I were more of an expert at reading logs… so in my opinion your tune is ok… when you look only at the input and attitude…but you still have clipping… as for hardware issue? I do not know, I switched cubes to the orange and havnt had as much trouble… but still saw a little clipping and was able to fix it follow advice from this group… try the following

  1. review your set up making sure all motors are true on the frame (not tilted but aligned… I see a gimbal, so do all flights and tuning with the gimble disabled (power off to gimbal) as if the motors have a hum the imu on the cube will pick it up…
  2. balance the props , your vibe looks low but perhaps it can be lower, also check the motor balance… I use KDE and tmotor , thus far I they are good from the factory
  3. the log provided did not appear to have a notch filter - follow @dkemxr advice and re-set the pids to factory then set up your notch filter - I have only ever need the throttle based filter - xfacta helped me get started, but instructions are here
  4. re-run autotune after the notch filter is added
  5. a good way to evaluate the tune is to look for oscillations especially watch as the drone descends… usually I run an auto-mission of a few way points then use the rc to return to launch…if oscillations seem severe, switch out of rtl to altitude hold and land… in this case you will need to adjust the PIDs (lower) until the oscillations stop…