Tradi Heli:RC Can‘t operate the swash in Loite rmode

Hello guys ! I have a problem, In loiter mode my helicopter cannot use the RC to control the swash plate operation, only the tail rotor can be operated
My FC is Matek F765 and Firmware is ArduCopter V4.0.7
Thanks for Help!

@Laoyaoguai software is not designed to work that way. Especially if you were on the ground and not flying. If you want to check proper swashplate operation, you will need to do this and stabilize mode or acro mode. Here is the wiki page that talks about testing for proper swashplate operation.

The vehicle has completed the test flight in the stabilize mode and can hover stablyd,The altitude can also be stabilized in the Althold mode,but the swashplate is not controlled by the RC in the Loiter mode

Hello all, I’m using Pixhawk FC with ArduCopter V4.0.7. I also have the same exact problem. My Heli performs well in all modes except when I switch to Loiter where I can’t roll and pitch. I can only control Altitude and Yaw in Loiter mode.

@JohnO please post log. That way we can see the issue and determine how to help you.

Thank you Bill, trying to upload the .bin file but it won’t let me saying the file is too long. I couldn’t keep the Heli (Trex800) in loiter too long. stared with stabilize then Pos. hold and last Loiter for a brief moment. I’ll look for another way to share the .bin file.

Just share a link to it on one drive or google drive.

is there a reason why you don’t have ARMING_CHECKS set to ALL. Are you purposely bypassing certain checks.

Also I noticed that you have ATC_RAT_RLL_ILMI and ATC_RAT_PIT_ILMI set to zero. These need to be set to a non-zero value for the integrator to be able to grow and help hold attitude. I would suggest setting them to 0.08. I don’t think this has anything to do with your problem but thought I would mention it as this helps the controller desired and actual attitudes match.

@JohnO So I can see that you are using the RSC mode that is the passthrough mode. That is not a recommended mode because if your transmitter was to lose link with the heli then it could cause the motor to shut off.

However the big problem with your set up is the value of H_COL_MID or the mid collective setting. This should be set so that the collective blade pitch is zero or the blade pitch that produces zero thrust. It appears that this is set for your hover blade pitch which is incorrect. It uses this setting to determine when the pilot has taken off. In your case, the flight controller never thought you had taken off and thus the loiter mode doesn’t work because it thinks the aircraft is on the ground. Please set this parameter correctly.

Thank you Bill and Yes, I agree. I need to revisit all my parameter settings to make sure it all applies to Arducoper 4.0.7. My Heli (Trex800, DDFP tail, 900mm main Rotor) flew perfect 2 years ago in all Modes when I was using Arducopter 3.5.3. now that I upgraded to 4.0.7 I noticed the parameters are very different. Thank you again Bill, will keep you updated with my progress.

1 Like

Thank you Bill, correcting the H_COL_MIN, MID, MAX solved the problem. Now I can roll and pitch in Loiter mode.

1 Like

@JohnO be sure to upgrade to 4.0.8. There was a bug in 4.0.7 that we just found and fixed. It was introduced in 4.0.7 by a change I made for integrator management but it affects the landing detector and can potentially shutdown the motor in auto mode. Here is the link to the post i made on it

Should I just upgrade to 4.1.0 official?

Stick with 4.0.8 until 4.1.1 comes out as stable. The fix is in 4.1.1.

Thank you Bill, appreciate all your help.

1 Like