Testing needed for major PX4Firmware update

here is the PX4Firmware branch for anyone willing to do review:

To continue what Mike said, testing on a Pixracer:

Spektrum PPM input(Satellite) now works - thank you!
ESC Calibration process works
My Esp isn’t flashed with the correct firmware, so I can’t test that right now.
RGB LED not working.

Compass calibration - worked as expected
Accel calibration - not yet successful, probably an execution issue though.It’s hanging at the last one (on it’s back) or fails. Accel calibration successful.

Motor test - this is not working as it’s telling me the command is rejected by the autopilot. “Safety switch” message shows up in the HUD though I have BRD_SAFETYENABLE at 0. I should try w/ safety switch soon.

Battery monitor setup w/ ACSP4 is working.
Compass_Mot calibration seemed to work.

I haven’t test flown it yet though, possibly tomorrow.


i flew it on a pixhawk based quad today and it flew fine, although the timestamps were not set correctly on the resulting DF log files. I’m looking into that

Scott, I’ll see if I can work out that is up with safety and motor test

RSSI has changed:

How do I use the new items?


Never mind, found it.
Tested quad with real Pixhawk controller:
Accel Calibration ok
Compass Calibration ok
Radio ok
ESC Calibration worked after pushing safety switch

Test flight worked in Stabilize, Altitude Hold, Position Hold, Auto, RTL, and Land.
Takeoff with Tower software with auto mission worked.
Relay switches worked.

No issues.


On Pixracer when safety button is excepted there is no ta-da sound.


Problem with Auto Tune. I did a test auto tune and it didn’t go well. After the auto tune the copter is not responsive and flew away at times. Was able to land with no damage.

Could not use mission planner to look at tuned values since the parameter names have changed and mission planner has not been updated to them.

I did notice that what ever I was set to so was P.

I did try to set them back to some older values and that seem to work as far as flight goes.


I messed with the motor test a little bit more. The BRD_SAFETYENABLE parameter doesn’t seem to have an effect right now. With it at 0 or 1 I see:

  • Safety switch starts out blinking
  • ESCs initialize on battery connection
  • Motor test is rejected by autopilot because of safety switch
  • Holding safety switch makes it go solid (no ESC beeps as they have already initialized)
  • Motor test works as expected once the safety switch is solid.

Also, timestamps in my logs are incorrect as well.


I’ve done a new build with binaries here:
this build fixes BRD_SAFETYENABLE on pixracer, and also adds OneShot and OneShot125 support.
If you want to play with oneshot, you need to:

  • have all copter motors on the FMU. On pixracer this is always true. On Pixhawk you need to use RCn_FUNCTION to put the motors on the FMU auxillary channels instead of main channels
  • set MOT_PWM_MODE to 1 or 2. Setting to 1 gives OneShot. Setting to 2 gives OneShot125
    The difference between OneShot and OneShot125 is that OneShot125 uses a PWM output range of 125 usec to 250 usec, whereas OneShot uses the normal 1000 to 2000 range.
    I’ve measured the latency for pulses starting after each main loop in oneshot mode on both Pixhawk and Pixracer as 25 usec.
    Testers welcome!
    Cheers, Tridge

ATC values not logged in PARM section.

I’ve pushed another binary for Pixracer that gets the WiFi working. It defaults to MAVLink at 921600 baud.

I tested on a Rover today. All went fine - no issues.
Well, I did have a GPS issue (I suddenly dropped from 9 to 4 satellites) but I’m certain that’s when I was enabling the GPS_SBAS_MODE setting. I normally don’t have it on but people are saying its supposed to be ok. I have nothing but trouble with it on my Rovers when I enable it.
Anyway, both tlog and dataflash links here in case you need them. Good to apply patch.
Thanks, Grant.

I see WiFi is working now. ESC calibration is working even without pushing safety switch with safety switch enabled.


APM serial number messages on Pixracer displays PX4v2 and not PX4v4.

This merge of PX4Firmware is now in master. Testing reports are still welcome!

So Tridge, that previous build has been superseded by master, right ?

@LuisVale, yep, I’ll remove them

1 Like

dear tridge
sorry for my english i am french
i just to buy this great little board to avoid imu2 problem that we can have with pixhawck…
i would like to use arducopter firmware…i am a newbie so i would like to know if everything working as well than we can have for original pixhawck or if it s always in beta…

the original is always out of stock…this seem to be great quality with alloy case

Sorry to reply

I believe you should get the original, that has tested and certified quality vs a unknown.

The original producers of the PixRacer actively support the ArduPilot project, so we should try to support them and get the products from them.

In Europe, it’s quite easy to get a PixRacer, don’t be fooled for the out of stock, just proceed with the purchase and you’ll get the PixRacer faster than you’d expect.

Si tu veux que le project Ardupilot continue, achete la PixRacer à Philip et Nick. La différence de prix ne paie pas (et la douane va te charger on plus de le prix annoncé)