Speed and Heading in real time from my RC sailing boat

Radio Rx to FC Tx, Radio Tx to Fc Rx, +5 and gnd. Ignore RTS/CTS. That’s it.

Thx that’s clear… and to be sure before I start soldering is UART1 the area I circled in red?

Yes. With this FC Serial1 is UART1. That’s not always the case.

1 Like

Yeah found their markings to be inconsistent when I was doing my research, hence why I’m asking.
So thank you - much appreciated :+1:

quick update -
I soldered the 4 cables from the RF telemetry onto the UART1 pins of the FC
I made and soldered the power cable to the + and - of the FC with a XT60 connector at the other end to connect to my lipo a 2s 1300mah I use for now.

I tested and when plugged in to my lipo the FC powers up and the FC too.
when I connect the other RF telemetry module to my pc then both find each other so bind properly

I have downloaded QGC on my machine plugged the FC to the usb port once I was on the firmare menu of the settings but nothing. I FC lit up and beeps once it starts but that’s it. No manual I found yet on that board which indicates what the LED and beeps means… They could do with a bit more explanations on their products… unless I missed that I need to have a degree in electronic engineering.

Oh and one reason I bought the M9 GPS & compass from Matek also is so I can connect it directly on the FC… BUT no they told me the M9 was more accurate than the M8 but didn’t tell me the cable wouldn’t work !!! :angry: :angry: now they say I have to either solder cables together or solder each cable directly on the FC !!! NOT GOOD MATEK… not good

I’m gonna download mission control next and see if the FC is recognised then

quick update #2

I finally managed to update the firmware on the FC via iNAV firmware update function but had to use Zadig to install the STM32 bootloader first.

So now my FC F405WSE has the latest firmware (3.0 stable).
and iNav recognises it. My FC is finally alive !!!

This only took me half a day :crazy_face: :crazy_face:


If I want to use QGC as suggested earlier in this thread I suspect I have to go through the same process to get the FC recognised by that application and upgrade the firmware to that of QGC for that board?

I tried to connect the FC (now working on iNAV) in QGC and it says I have to update the firmware.

So am I right to say the firmware version needs to be flashed by each Ground Application be ArduPilot Mission planner, iNav or QGC so it can detect the FC and share data?

Why iNav if you are posting here in Ardupilot? Install ArduRover.

Mission Planner supports Ardupilot. QGC supports Ardupilot and the PX4 Flight stack. iNav is iNav an offshoot of BetaFlight. If you are going to continue with ArduRover it’s best to use MissionPlanner for setup/configure/calibration. After that you can use QGC or Mission Planner as a Ground Station if you like. If you want to run the PX4 Flight stack or iNav you are in the wrong forum.

Getting speed, heading and other data is very simple, no need for any code changes or hardware changes. But you do need to use ArduPilot FW.

Thanks for your responses. While all this is logical and familiar to you, it’s not yet for me :wink: and documentation is rather poor so using youtube videos with whatever docs I can find to learn how to do this. Hence my question.

Yes I want to get it working on ardupilot.and use QGC.
I did try to get it to work on Mission planner but no success I just wanted to see if I could get it setup on any system (which I did on iNav) so I know the board works… now I need to get it working on Mission Planner. Which is what I’m trying to do atm :wink:

Even with Matek the M9Q GPS/Compass doesn’t plug into the FC with the cable provided. only the M8Q version does… I found that out yesterday (I did assume it would tbh). They use a JST-GH connector on the GPS board and a JST-SH connector on the FC board and the wires have different order so I have to either solder each wire directly on the board which I found out yesterday using UART3 or make a new cable.

For now I opted to make a new cable as I need the GPS to be min 10cm away from other components for a clear signal from what I found out so I ordered a JST-GH pig tail in 6 cables and JST-SH connectors and I’ll make that cable myself then… so for now the GPS is out until mid July when I expect to get these parts.

It’s not a smooth operation… don’t mind that too much as I learn as I go along and I’m grateful of your comments to steer me in the right direction which is key for me.

First you have to flash Ardurover to the board. You can use the iNav Configurator to do that if you want. If iNav is on there now Mission Planner won’t work to flash it. Follow the instructions here for “Flashing Firmware”:

IMO YouTube videos will be disappointing. The Wiki is comprehensive once you know how to search for things.

THX @dkemxr I followed this instruction and my FC F405S WSE is now live on ardupilot Mission Planner.
I used the Ardurover firmware of this board as you recommended.

I did try to run QGC and the card is also recognised there so good but it gives me a warning message that some parameters are missing. no error message or warning on MP.

Now, until I get my JST pigtails to make that cable for the GPS I’ll focus on the telemetry as I already soldered the wires on the FC.

So I’ll look on that tomorrow. But for now Happy to see it working on Mission Planner.
Thx for this great link. :+1: :+1:

Quick update:

I installed MP on my Android phone and plugged in the holybro RF telemetry.
I powered the FC with a battery and connected the other holybro RF telemetry.
and it worked :grinning:
So I know the RF telemetry is working with my setup.

Any tips / recommendations welcome as all this is new for me :slight_smile:
As you can see I did what @dkemxr recommended to flash my FC with Roverpilot so now my FC is working when connected via USB to my laptop and also I tested this morning with the RF telemetry Holybro on my Android phone and it’s working too.

So until I get the JST connectors for the GPS module, what can I do now?

Not much without the GPS connection. But you could try to monitor battery voltage and current if you add a voltage monitor board.

I suspected as much as speed, heading will come from the GPS module.
I went with the M9Q model over the M8Q as recommended by Matek themselves in response to my question which of the 2 is the most accurate as accuracy is important for my project here.
What they omitted to tell me is that the JST plug they use is different for the M9Q module…now I have to wait another 3/4 weeks for a new 6 pin pigtail in JST-GH to arrive and I’ll connect a JST-SH to connect to the FC.

Battery voltage is not too important in this project since telemetry is not allowed in racing I can only use this in training so I’m building it to be a completely separate box from the boat RC components… probably attached on the boat with velcro but need to test that. I know in racing condition a 800mah 2s lipo will last me nearly half a day … will last more but I always change half way to be sure.

What I could do is the battery monitory on the battery powering this telemetry setup as I have no idea how much power it will take. I suspect not much but I’ve no idea. But that’s a good idea. I’ll look at options for a battery monitor board then… but let me know if you know of a good one I could use.


ordered this power module to use on this project.
Not critical to this project but I’m curious on how to set it up anyway :slight_smile:

The F405-WSE has onboard voltage and current sensing…