Setting up Trex 450

I really didn’t look any further once I saw that. There’s no point looking at anything else until you get the vibes more reasonable, as the rate controller won’t work properly either.

450 trad heli with Pixhawk
I have just installed ver 3.1.5 firmware and reset to factory defaults in Mission Planner.
On setting up Rate_RLL_P , I got a figure of 0.075 before it oscillated. I dropped this to 0.07.
In the parameter table it shows a range of 0.08 to 0.20. This range was a lot lower before.
where the setup range using Ch6 was 0.0100 to 0.0750.
Has the value been changed?

No, these ranges should not have changed. There are no functional differences for TradHeli. Your old values should still be fine. And that range description applies more to multirotors.

I guess somebody changed the range that is quoted without talking to me or considering TradHeli. That type of thing happens a lot (again, this is not a functional change, just a change to the user notes). Sorry about the confusion.

I’ve been slowly moving as many things as I can to be separated from the multirotor code so that this stops happening, but I can’t get them all.

OK Rob Thanks for the info, but it is a bit off putting when you are still learning about setting up the Trad heli. So what you are saying is that the default parameters are mostly for the Quads etc. Is there a revised set of parameters for the Trad Heli?

Not really unfortunately. This is something that is continually asked for, but I’ve never had time to put together. It really needs input from you guys, and it would be helpful if somebody took it on to manage it.

Rob ,

Replaced the main shaft , tail shaft and installed new vibration isolation .

The vibration has come down significantly.

The weather was windy , so could not try loiter for long , however when moved to loiter the helicopter had a tendency to go into Toilet Bowl Effect (TBE)

Will be doing more experimentation , awaiting wind free time.

I have attached pics and logs

  • Log with ‘Loiter’ ( wobbled little bit, Rate Roll P .065 and Rate Pitch P .07 )
  • Log with 10% reduced gains , this make it more stable in ‘stabilize’ mode only( Rate Roll P .05 and Rate Pitch P .06 )

Here is the log in which I try Loiter and it goes into TBE . Not sure what is wrong .The vibration values are really low as I have shown above . I am attaching collection of my compass calibration screen shots I tried both Randy Calibration method and Chris Anderson Calibration method … padvanced/

I will try calibrating it again in open field with no metal object nearby . I am currently trying to calibrate in my house roof and might have some steel reinforced concrete pillars.
Good link for what to watch out for : … clination/

Last time 4 months ago I tried compass calibration in open field it did not decrease the TBE. (probably that time I had major vibration issues plaguing )

Here is the log with Loiter

And screen shot of declination values .

Rob and other experienced Heli fellows.

( Main Problem ) Okay today I tried all possibilities. But I am still getting whirlpool (toilet bowl effect ) problem when I switch to LOITER.

I went to open ground , no metal (ferrous) objects near by and tried calibrating compass.

a) Calibrating compass by randy and chris anderson method

b) Flew the helicopter in all orientation for some time 2-3mins and tried doing Log based compass calibration but to no avail it does not work , it did not give me any offsets.

c) I suspected that the APM might not be correctly aligned so , removed my new vibration isolation and installed a flat board like how it is recommended in APM documentation for helicopter mounting, mounted it using gyro tape (soft double sided tape) , but to no avail, TBE persists.

d) In the end when I was left with no option I tried changing Loiter Gains P from 1.0 to .4 and I from .5 to .2 and D from 0 to .01 or .1. but to now avail.

In stabilize mode, my helicopter flies fine however its sluggish, I am able to control it without much issues , only thing is that it is slow to correct , very sluggish ( rotation -roll / Pitch rate are slow ) . Is there a way to make it more agile increase the rate of and pitch and roll ?
( BTW I have tried increasing gains of Rate Roll P and Rate Pitch P to as far as I can, beyond this it makes heli oscillate fast. (current Rate Roll P .05 and Rate Pitch .P .06 ) )

Attached is the log file ( I have many times switched to ‘loiter’ in these flights as I calibrated compass numerous times hoping it will correct, so multiple take off and landings are here )

My effort and testing seem to be going totally fruitless , so any help will be appreciated.

Rob, if you notice I don’t have ‘Mag’ data in my log file ? Isn’t that strange.

No wonder log based calibration of compass din’t work !

Anyways another thing when wrong today , after I recorded these log , my laptop went to hibernate while doing compass calibration and now the APM is not allowing to enter compass calibration, getting serious stack of errors . I have posted it on 3dr support forum as I tried all erase ,reset , firmware upload, reinstall Mission planner (deleted old folder) etc but to no avail. You don’t have to answer it, thought I’ll share with you . So I guess my hardware is bricked for now !.

Puneet, I looked at your logs again. Your vibrations are better, but still too high for Loiter. The controller is likely getting all confused, and is probably even causing you problems in Stabilize mode. You need to get those vibrations down. Have you checked the blade tracking? Balanced the blades?

Also, I notice that your Rate Roll and Pitch FF numbers are still close to zero. 0.006. Previously I instructed that you should try increasing these. Start at 0.010, and increase by 0.005-0.010 at a time until you get some better control. Though this is still somewhat risky with that much vibration.

Your Rate Roll and Pitch I-terms are also much too low. You have 0.04496, you should have at least 0.100, and I typically run up to 0.500. The Imax are also too low at 500, these should be at least 2500.

You are fighting to get Loiter working, when the helicopter is not even flying properly yet. It will never work like this.

[b]hello guys,
can you tell me how can I do to have a throttle curve on channel 8 using apm?

how do you manage the throttle curve ??[/b]

Hello guys, Im a newbie, and my machine is a HK450 Flybar. From now on I am looking for APM parameters pre-set to load into hardare and fly as simple as possible. Once Ive made all nedded calibrations during using Mission Planner, are there any trick to do basic flights and open circuits? Which parameters should I vary from preset values for very stable flight

Typhoon Motor
Castle EDGE 50 ESC (it has governor mode and gain wire)
Three digitals HM10 XMB servos in CCPM
Align DS525M for rudder
Gyro JR270 3D
Radio Futaba 8J FHSS
APM with GPS module, compass, barometer, magnetometer

Lucas: There is currently no way to use a throttle curve in APM. You are best to use an ESC with a governor function. If you must use a throttle curve, you’ll have to do it in the radio, and then pass it directly into the ESC from your Rx.

kbadra: I don’t think you’re going to be able to get parameters that will get your helicopter flying without spending time testing and tuning. There are so many variables, and they’re different between all helis.

Mr Lefebvre, thanks for advising, I was looking for parameters configurations in an easy way, because I don`t know what is happening… all the servos are twitching when the power module is plugged. My servos are analog, do they need to be digital?

Some analog servos can work with Arducopter, but not all. And it’s just generally way better to use digital anyway. I’m not even sure why anybody is still selling analog servos in 2014 frankly. There are plenty of affordable digital servo options.

Mr Rob,

I got it, the problem was an error Ive made in calibration step, so the board did not arm. I have done it many times till I found the right way. Although it all works, there is still an issue, I dont know how to right setup the CCPM Mixing and it does not matter what I do in Radio, it does not change. It is like an inverted channel in HR3 Futaba setting... but this is made directly in the board, right? In Radio Ive put H1 swash plate option.

How can I fix this?