Rover-3.4.0-rc1 released for beta testing!

Really nice analysis.

I totally agree. Actually I hit this issue yesterday on my high speed boat. I just could not get it to turn quickly at high speed even though it would turn on a dime in manual mode.

When I made the change you’ve found, I recognised that this could be an issue (it’s mentioned in the PR but that reaches a limited audience) but hoped that we could get away with it. I might work on this today.

I guess you would vote for us holding off on Rover-3.4 release until we fix this? I’m keen to release 3.4 but lose of steering control on high speed vehicles is a serious issue so I think we probably have to fix it first, then release -rc2, test that and then finally release 3.4 officially.

EDIT: I’ve got a fix here that I’m testing.

Given that the lane following looks close to being done, could you incorporate that into 3.4-rc2 with a flag to turn it off - it’s not entirely clear from the lane following how to disable it.

Re your fix, it doesn’t look like you’ve removed the +/-1.0 constraint at the end of AR_AttitudeControl - that’s the critical one.

1 Like

Txs, I’ve removed the limit from AR_AttitudeController and created a PR to get this fix into master.

Re the lane based throttle control, I think it might be best to push that out in a point release (i.e. Rover-.3.4.1) so we can get 3.4.0 out sooner.

David Hello! Can you post your full parameter list for 3.4.0-rc1

This is it.3.4 beta initial.param (11.9 KB)

Not trying to beat a dead horse, but, here is one last video of the boat turning during a survey grid.

1 Like

Love the videos! Looking good!

By the way, there is still a bit more we can do to improve performance at corners. There are at least two remaining issues that I’m sure we will fix in an upcoming release.

Thanks David ! Thanks rmackay9 !! I understood very well !!! David can you send me your boat data. Where to order. Maybe a picture or a video?

It’s home built.

1 Like

David will show steering and drive?

This should do it.


Yup, that’s looking good!

Very good!!! Thank you.

David your parameters servo 1 = 26 ; servo 3=70, and your boat has two engines? Is this normal?

Didn’t notice that. I would have to look at Mission Planner or the Wiki and see what that all means. I think its normal for this configuration because I did not enter those values and the boat works. Keep in mind the two thrusters work off the same PWM output of the Pixhawk 1.


It sounds like your boat uses the separate steering and throttle setup so what you have is correct. Presumably the two rudders rotate as well to provide the steering. It is possible in Rover-3.4 to use both skid-steering and regular steering on the same vehicle. So for example, it could adjust the speed of the two thrusters to provide additional turning which might be good at very low speeds or in a strong current. That hasn’t been tested though so I’m just throwing info out there. Probably not what you want/need.

txs again for the pics!

1 Like


Having skid steering for holding position and then regular steering for regular travel would be great. I did not know this was possible and I am glad to test it. Is this in the Wiki?

Hi David,

To enable using both skid-steering and regular steering, the two motors should be connected to separate outputs on the back of the flight controller. Then the appropriate SERVOx_FUNCTION should be set to “73” for the left motor and “74” for the right motor.

The servo output connected to the steering servo should be left at “26” for “Ground Steering”.

This combination isn’t documented exactly on the motor-and-servo-configuration wiki page but some info for each of the two types is there. It’s untested of course so it may not work but giving it a try and reporting back would be interesting. If it doesn’t work we can potentially try and fix it.

Hello rmacky9.
Randy I need your help. AR 3.4.0 I have a problem with a servo 3. The default setting is 70 throttle. The servo output is inactive. I manually change the KIN3 to become active. Could this change cause problems in auto mode? When it switches to auto mode does not start itself. It is necessary to manually determine the speed of the joystick. The car goes in the opposite (-180deg) direction from the set waypoint.

1 Like

Param list.param (11.7 KB)