Problem starting Pixhawk

I’m getting the tone described by “New IO board firmware found (restart with safety button pushed to upload)”. How do I resolve this problem?

Waiting does not work ?
Just let it play the tones for up to 15seconds… it will usually complete by then.

Here is an audio file of the start up and tones. No main colour light shows at all. See below. Frustrating but hopefully recoverable.

Pixhawk (38.8 KB)

Stock boot up sound plus - New IO board firmware found (restart with safety button pushed to upload)

Yes, I found that too. But what can I do to resolve the issue? Very frustrating and I’m told in all the literature how much protection there is built into the Pixhawk. Well, it hasn’t helped me!

Well it hasn’t uploaded firmware.It’s asking for the restart with the safety switch pushed in to complete.Did you reboot with the switch pushed in ? (just pull the USB and then plug it back in).

Which firmware did you flash to it ?

It may be worth a flash with a different type of firmware and then a reload of the one you want.

It’s also always worth trying different USB leads.The Pixhawks can sometimes be a bit picky.

I have tried everything you suggest except change the USB lead which I will do. I’ve now got two Pixhawks with the same problem in less than a week! I have been trying to power the unit with a 2S LiPo. It didn’t seem to like that with the buzzer beeping low voltage fail safe but that shouldn’t damage the unit surely?

In the photo above you just have it powered via USB.You may not have enough amperage from that USB port.In which case a powered USB hub may help.Or another port on the computer may have a larger output.

In the photo the unit is on the bench powered by USB.So where does the 2S battery come in ? After it’s fitted to a copter ? Through a power module ?

1 Like

I’ve uploaded the latest firmware (3.5.4) and have tried again but it still gives the same result. I have now included a parameter file below as well as a photo showing the set-up with the 2S LiPo - note no light and no flashing safety button and the FMU B/E light is off, all other lights are on (see pic). I have used a different USB port with the 2S power source applied but am still getting the same result. I have loaded a new audio file so you can hear the tones.

This same problem has now happened the two Pixhawks I own, and in less than a week!

Pixhawk Failed To (45.6 KB)

I can connect to Mission Planner as you can see below:

Here is my parameter file:

4 Jan 3.12pm - Start-up falied.param (11.8 KB)

The reason why I have the Pixhawk on the bench is to get it set-up before installing it in a heli. It’s easier to work with while its on the bench. If I get it working I’m then going to install it in a Hirobo SDX Nitro. But at the moment its going nowhere!

I think it’s a no-no to power the Pixhawk from USB and the power port at the same time. It burns something out on the board in the power circuit.

My understanding is that you can and someone suggested I should as it ensures the thing is properly power at best and at worst it gives you power redundancy.

I was trying to piece together what might have happened before I lost both Pixhawks and the one thing that seems to be common is that I used a 2S battery through the 3DR power module (Ver 1) and got a beeping sound like “low battery alarm”. When I reconnected I had the problem.

Chris, do you think I’ve cooked both my Pixhawks?

No, I don’t think you can hook up both USB and external power at the same time. It burns something out on the board. If they don’t light up I’m thinking whatever it is that burns out is burned out.

If you have a Pixhawk connected to a lot of devices, Gps, 433mhz radio module, external led, etc. it is the only way to have a successful connection via USB since the 500ma of USB pc port would not be enough to power all the system.

I have done it several times without problems .

ozsteel, did you check with a multimeter the voltage at Pixhawk pins ?

Luca, exactly which pins? I’m no expert so need you to explain in more detail.

Chris, thinking about it, it might have been connecting both the USB and a battery at the same time that caused the problem but as you see, others have done so without problem so I’m a bit stumped. The warning I got could have been as a result of connecting two power sources at the same time. I must admit, it surprised me to get a warning as I haven’t set the any failsafe.

If I’ve burnt out two Pixhawks maybe this tread can save someone else from doing the same. Lets just get it settled - can you connect two power sources or not?

Be very careful not to touch with multimeter probe positive pin and other pins at same time

It would be more simple to check the voltage enabling via Mission Planner the voltage sensor.

Connecting at the same time USB power and main power will not damage the Pixhawk, of course you must check that your power module voltage output or Pc USB voltage otuput are at 5,7 volts maximum for normal usage.

I suggest to take a look at Wiki for more informations:

The parameter list shows that the board is not being recognised and very little else.

Being that the USB lead is common to both Pixhawks I’d try that first off.I’ve thrown USB leads away for similar problems in the past.

OK, I’ve had a look at the link in Luca’s post:

Voltage ratings

Pixhawk can be triple-redundant on the power supply if three power sources are supplied. The three rails are: Power module input, servo rail input, USB input.

Normal Operation Maximum Ratings

Under these conditions all power sources will be used in this order to power the system.

Power module input (4.1V to 5.7V) [refers to the voltage coming into Pixhawk from the power module]
Servo rail input (4.1V to 5.7V)
USB power input (4.1V to 5.7V)

Absolute Maximum Ratings

Under these conditions the system will not draw any power (will not be operational), but will remain intact.

Power module input (0V to 20V) [refers to the voltage coming into Pixhawk from the power module]
Servo rail input (0V to 20V)
USB power input (0V to 6V)

So it seems you can power from three sources at the same time! And I sure didn’t exceed the maximum ratings either.

So, what’s wrong with my Pixhawks???

Well, as long as you can hook both USB and power at the same time (I can’t remember where I read that - maybe it was from the APM days), try a different USB cable like Jagger suggested. Some of those USB cables are made only for charging cell phones and stuff and they don’t have any data wires in them. I know I do have one of those around here someplace that won’t communicate but it will charge a cell phone.