" PreArm: Waiting for Terrain Data " I couldn't get rid of the error


I think it loads terrain data for about 2km around the home position. It also loads the terrain for any waypoints in the auto mode mission.

Normally once the terrain data has been loaded to the autopilot (e.g. terr_pend = 0) it won’t need to load more during the flight. It depends upon where the vehicle flies to. Still, not having the terrain data should only cause problems if you’re running an auto mode mission with the altitude frame for the commands set to “Terrain”… or if you trigger RTL mode and the RTL_ALT_TYPE = 1 (Terrain).

1 Like

@xfacta Thank you for your valuable information. I did a compass calibration indoors. However, I have never calibrated outdoors. That’s why I did a compass calibration once outdoors.

@rmackay9 Thank you for your valuable information. Outside, the autopilot receives the terrain data from the ground station. The error is lost. However, it occasionally gives the same error when outdoors. It disappears immediately. After flying in GPS mode, it gives the same error even in Stabilized Mode indoors. At the moment, I have uploaded the land data of the whole country (Turkey) to the SD card. But the error is still not fixed.
I’m glad to hear that you will take care of the error. Thank you.
NOTE: Also, I don’t know if it has anything to do with the error, but I am connecting with Autopilot via wifi module. In other words, there is no internet connection at the ground station at that time. Then I give internet to the ground station and it receives the land data. Then I connect to Autopilot again. The terrain data (DAT file) is being uploaded to autopilot. Error is fixed. But indoors, it gives the same error in stabilized mode. In addition, the SD card has all the country’s terrain data.

I see - that’s good.
I’ve seen where people think they have t calibrate the compass at the start of each flying session, and it’s not required.


Confirmed: I currently have PreArm waiting for terrain data after installing arduplane 4.3.4 stable as well as a PreArm: AHRS: not using configured AHRS type error.

ARMING checks do not have a “terrain data” check to disable as part of the Pre Arm procedure.

ter_pend is 57 and not moving
ter_load is 335

I have a TERRAIN folder on the SD card and I deleted the 3MB worth of .DAT that was in there. Rebooted the autopilot and reconnected to my desktop (via USB cable). Same pend and load numbers as above. I expected those to go to zero but maybe its reading the .DAT files on my desktop??

I read through the entire thread here and I’m thinking it is a bug its just not fixed as of 4.3.4.

BTW: My last bird ran into a guy wire and destroyed itself. Terrain following was not able to be turned on (could not arm) and I had to guess as to how high the tower was, turns out it was higher than 300 feet.

Bad day all around that day.

@Chad_Frazer get well soon