Pixhawk 2.4.8 Firmware?

I bought one of these MRo Clones from China. The specs that went along with it say it is an updated version with a 2meg ram. My question is, when I load the firmware, MP asks which pixhawk I have Type 1,2, 2.1, 3 or 4. Which one should I use? I know it’s not 2 or 2.1 but their are other choices and the right choice would help tremendously.


From the Mission Planner Install Firmware Screen select “All Options” and then these selections assuming you want Copter. If you want Plane or Rover pick those .apj. It should do the trick.

Hi Dave.

The firmware manifest ask what type of platform I’m using. I’ve tried several that seem to work but the 2.4.8 board is not listed. Any idea which would be most compatible?

Rick J Riggins
2585 E Pikes Peak Ave. # T-101
Colorado Springs, CO 80909


(719) 219-6884

Why don’t you just try what’s shown in the image and as instructed? If your Mission Planner screen does not look like this update it from the Help screen by pressing the “check for Beta updates” button at the bottom of the screen.

Good day, for your pixhawk you can use platform FMUv3… in case you see few issue with this version just choose FMUv2

If FMUv3 doesn’t work you might find updating the bootloader sorts it, both my clones (not MRo) were detected as FMUv2 but they had the fixed chip so with an updated bootloader work fine and are now detected as FMUv3.
Qgroundcontrol can update it and has instructions if you google update pixhawk bootloader.

QGC will do it and Mission Planner will also simply by selecting fmuv3 as the Platform.

Oh, I didn’t realise that would also update the bootloader, is that persistent or do you have to select the other platform each time you update rather than letting it select for you? I did try using mission planners update bootloader (in the control f menu), but it failed everytime for me, although it now works after updating it with qgroundcontrol.

It’s persistent once you update it.

Thanks to all the contributors, their help proved extremely useful! I found this thread searching for a solution to upgrade two boards that refused to be recognized by the mission planner firmware update tool.
I have no tools to know why this happened but an entire day of trials did not solve the problem, bootloader update didn’t work and anything i tried was vane. I am writing now because i have been able to update both boards (a 2.4.8 with 2 mb and a hobbyking px4 clone) in 15 minutes just using qgroundcontrol…without having ever been using it before one hour ago.
Process is:
Launch qgroundcontrol, connect board, pressing firmware update
QGC asks to disconnect the board and reconnect it
Upload px4 firmware (not ardupilot)
reconnect the board, wait for the parsameters loading and then go to parameters
search for the parameter sys_bl_update, set it to 1 (enabe)
disconnect and reconnect the board, this will update the bootloader
At the end the board reconnects automatically, wait for it
Disconnect the board and reconnect, before parameters are loaded you can press firmware
Load latest firmware, using fmuv2 option, try fmuv3 if it doesn’t work BUT this time set ardupilot firmware.
Firmware will load, once finished disconnect everything, quit qgc and you’re ready to connect a firmware-upgraded-board to mission planner.
Don’t know why firmware update with mission planner went so difficult, it was fast and straightforward but now, surely because i must have made some mistake at a certain point, was impossible.


Saved my day, would have never thought to use QGC to update firmware, thank you.

Loading firmware with QGC is just life-saver if you are having trouble.
I had a Radolink pixhawk and only QGC on linux did the job.

Thanks a Ton.
I was fixated on Mission Planner, tried this QGroundControl & it worked just fine…!