Passthrough telemetry over CRSF (crossfire)

I know nothing about the TBS cloud or WiFi, can you explain how to reproduce your setup?

in system menu, go to lua crossfire config lua script, then select XF WIFI. After choose AP mode or Client Mode. I was using Client Mode, so I had to enter my wifi SSID password (painfull with, TBS agent Win10 client is much better). Then the Wifi Agent is connected.

So as soon as you connect it it starts sending parameters query? That bad

Hi @yaapu Some good news i got it working on custom H7 board, with crossfire full size module and micro RX on a RadioMaster TX16s. No GPS lock as i’m indoors. As mentioned above went into crossfire script and pressed forget wifi, after that no issues.

On a side note i’m sure i read somewhere that its possible to use Mission Planner maps for your map widget/script but cant find the post anymore.

Anyway great App from a first time user,

Malc

Great! What are the exact steps to trigger the WiFi issue, I don’t seem to be able to reproduce it :frowning:

MissionPlanner maps support requires 1.9.3, docs are here https://github.com/yaapu/FrskyTelemetryScript/wiki/Offline-Google-Maps-download-and-use

I’ll turn on wifi again, i never tested it with your Script/App but had some issues finding sensors when wifi was on, after seeing post above i turned it off, so i’ll trun it back on and report…

Thanks for the link

Just to make it clear, the WiFi/sensors issue is because @andyp1per and myself agreed on having a very high priority for parameter processing, whenever a parameter request frame is detected the CRSF library does it’s best to process it as fast as possible which is OK if the user is inside the LUA script and does not care about smooth telemetry but otherwise leads to telemetry slowdonws and “apparent” freezes because we actually disable custom passthrough telemetry for serving parameter responses

Unable to trigger the issue with WiFi in AP Mode, trying STA mode now.
Note: the TBS Agent running does trigger the issue since it continously requests parameters on the CRSF bus

So have reconnected the TBS wifi to my home wifi network and can see the it in the Router, Radio app is slow when connected to TBS Agent but as soon as i disconnect the refresh rate, hud etc goes back to normal. So actually it works fine when connected to wifi, but i dont see the point as it cant pass anything to mission planner in CRSF mode ?

CRSF is not mavlink :slight_smile:

If you enable mavlink while using CRSF as RC protocol you get a mavlink emulation layer that converts CRSF telemetry coming from the FC to mavlink messages but it is one way only FC -> CRSF -> TX -> MAVLINK ->WiFi -> GCS and according to users not mature yet

i realise that… :wink: i didnt know that you could set it up this way…
I shall try it now …

haha, if you check older messages you’ll se that both @vierfuffzig and @andyp1per use it

Ok so yeah i see it trying to connect but its not great lol… :wink: i’m on latest XF beta FW, when it works it will be very useful but for now i’m happy with the your App on the radio, :slight_smile:
As i’m typing its still trying to get params…

…it will never download any params for it’s one way only :frowning:

Well, i’m happy that its working as i never used MP over wireless much anyway… Doing the maps now… :slight_smile:

1 Like

Added builds for latest test version 0.10

This requires Yaapu Lua Scripts >= 1.9.1 downloads:

should i try this one maybe it now works on my Taranis x9d+

bro tried everything, even this new ardupilot fw still no result, although all the sensors were found 23 to be exact, i can even set a basic telemetry page with all data but Yaapu is not working, most of the times it says No Telemetry , sometimes out of a 20 reboots it shows rssi in top of the screen and the No Telemetry blinking msg changes to Disarmed but even at that time its not showing any data like battery voltage gps coordinates etc and the horizon also never moved for me even once, i have no mavlink its crsf on tx and rx, i even turned off mavlink inside the TBS crossfire, in the Yaapu debug i can see msgs of being in rfmd mode 2 with 146hz sometimes 153hz speed in mode 2, it even gives that warning sound for bad gps etc and i can see it in Yaapu at the bottom of the script and also in the debug, even rewired everything updated opentx to latest and tbs is already 4.0.8
SERIAL1_PROTOCOL = 23
RC_OPTIONS = 32+256 = 288
BRD_ALT_CONFIG = 0
rx connected to UART1 from Ch1 and Ch2 of the micro v2 rx
what do you suggest should i give up or keep trying?

Alex, Did you suceed to reproduice the issue in wifi STA mode ?

anyway, my intend was to have a mavlink stream available as a backup link for my groundstation.

In order to increase available bandwidth for mavlink, it would be great to be able to set the max passthrought update frequency on ardupilot, using for instance a param “RCTELEM_PASSTHROUGHT_MAX_RATE” like the SR1_XXXXX param.

Never give up:-)
it must be something trivial since up to now you’re the only one who can’t get it to work.

Download mavproxy, we need console output, flash this debug version for MatekF405-Wing
arduplane_crsf_debug_matekf405-wing.zip (644.5 KB)

Run “mavproxy.exe --master [your comport]” where comport is your windows serial port connected to the matek board.

output will be like

APM: CRSF: RF mode 1, rate is 160Hz
CRSF: multi passthrough
APM: ArduPlane V4.1.0dev (62ce1aa9)
APM: ChibiOS: 331fe75d
APM: MatekF405-Win 00470043 304B5013 2036334
APM: RCOut: PWM:1-10
APM: IMU0: fast sampling enabled 8.0kHz/1.0kHz
CRSF: text passthrough
Received 1317 parameters (ftp)
Saved 1317 parameters to mav.parm
Flight battery 100 percent
CRSF: single passthrough
APM: CRSF: RF mode 2, rate is 159Hz
CRSF: text passthrough
CRSF: single passthrough
CRSF: single passthrough
CRSF: single passthrough
CRSF: single passthrough
CRSF: single passthrough
CRSF: single passthrough
CRSF: single passthrough
CRSF: text passthrough
CRSF: single passthrough
CRSF: single passthrough
CRSF: single passthrough
CRSF: single passthrough
CRSF: single passthrough

copy this debug script Yaapu CRSF Debug.zip (1.3 KB) to /SCRIPTS/TOOLS/Yaapu CRSF Debug.lua, and run it with long press [MENU], browse to tools page and execute it, it will create a log file and show which packets you are receiving and log them to file

image

Edit: these are my params (bench board, no tuning) RX is connected to matekf405-Wing serial1 matekf405-wing_crsf.parm.zip (6.7 KB)