Overcorrecting tendency whenever coming to a stop from forward flight

Below is what I got form the Mission Planner auto diagnose:

Log File C:\Users\FBI\AppData\Local\Temp\tmpB0D4.tmp.log
Size (kb) 11558.3095703125
No of lines 139036
Duration 0:05:09
Vehicletype ArduCopter
Firmware Version V3.4.6
Firmware Hash e707341b
Hardware Type
Free Mem 0
Skipped Lines 0
Test: Autotune = NA -
Test: Brownout = GOOD -
Test: Compass = FAIL - Large change in mag_field (50.20%)
Max mag field length (650.25) > recommended (550.00)

Test: Dupe Log Data = GOOD -
Test: Empty = GOOD -
Test: Event/Failsafe = GOOD -
Test: GPS = GOOD -
Test: IMU Mismatch = GOOD - (Mismatch: 0.29, WARN: 0.75, FAIL: 1.50)
Test: Motor Balance = WARN - Motor channel averages = [1485, 1474, 1377, 1392]
Average motor output = 1432
Difference between min and max motor averages = 108
Test: Parameters = GOOD -
Test: PM = NA -
Test: Pitch/Roll = NA -
Test: Thrust = NA -
Test: VCC = GOOD -

You should try increasing ATC_THR_MIX_MAX to 0.9 which is recomended in the AutoTune documentation for copters with large props / high power to improve attitude control.


Thanks juzzle1, at soon as repairs are complete I will try your suggestions.

Reading up on the Autotune page, it states that for large props application it is recommended to lower the settings to 10HZ for (ATC_RAT_RLL_FILT, ATC_RAT_PIT_FILT).Can someone explain how does that affects flight behavior? Since my setup is already pushing the limits of power to weight ratio can I benefit from trying even lower filter settings given my current setup?

OK I have another question: could I benefit from added flight attitude stability by enabling voltage scaling on my setup since I fly with Lithium Ion battery? With these batteries I can safely deplete the battery pack from 25.2V fully charged down to 18V or 3.0v per cell.


What settings do you have for your BLheli esc ?

How many Watts for hover ?
You should be around 320W with 17" props.

Voltage scaling is probably a good idea in your case as there is such a large difference between max and min voltage. I don’t think it will fix your problem, but will make the copter feel more responsive even when the battery is nearly empty.

I’d just try one thing at a time until you’ve got it stable.

it hovers right around 10-14 Amps. Never calculated hover watts. As far as settings I ve the timing set at med-low and voltage cutoff disabled.

Jose , your configuration is quite extreme, large battery , large and heavy props , low efficiency , with this setup you are hovering close to 1C and in windy conditions you can stress quite a lot the battery that remember is only a 3C battery.

I would enable voltage scaling and use damped light setting for esc , this should help a lot.

What does damp light will do? Just corious about the effect. Thanks for reply!!!

Will help to reduce inertial effect of your prop slowing down it

Do not increase ATC_THR_MIX_MAX to 0.9 it will make your problems even bigger…
Can you flash your ESC with newer firmware?
You are using 13.2 version(2 yrs old) and new is 14.9 i think…
here is mine settings

After that my advice is to turn of #Programing by TX# in BLHeli settings…
Use voltage scaling for sure,but be aware when you battery is near end…
With filter,You can experiment with even lower filter settings but not higher than 10Hz…
Your copter is very overpowered…hoover at 15%-20%!!!Maybe to try add additional weight…
Also maybe your PIDs after autotune are too high,try to lower them for 15-20%(all pids equal percentage )
Also…you are using 3.4.6 instead latest beta wich is 3.5 rc7

@emin_bu While the ESCs could be the issue and always worth elimiating I’m curious as to why your’re suggesting ATC_THR_MIX_MAX will make the problem worse?

The documentation states 'This can reduce the pitch overshoot sometimes seen (especially on copters with large propellers) in AltHold if the vehicle suddenly slows after performing fast forward flight. ’

The OP’s copter fits all the criteria for this setting - large props and pitch overshoot when slowing in alt hold.

I doubt it will make the problem worse. The possible side effect would be that it may be difficult to reduce altitude in a mode that is using the Baro. In this case, switching to stabilize will allow the copter to descend.

Additionally, suggesting someone having this kind of issue should upgrade to a beta release is generally not recommended here.

The possible effect of fiddling with ATC_THR_MIX_MAX will be adding another unknown variable to complex problem…
Do you really know what that parameter means and in what corelation is to others?
For sure he should upgrade to latest beta 3.5 at the moment RC7…
Betta is more stable than 3.4.6 will ever do…lots of things changed,check it yourself
With 3.4.6 he can not even see all the data from Pixhawk 2.1 he uses,and also he can not see some problems bcs.3.4.6 does not registrate them…

i suggest…reset all…do a clean start with 3.5 rc7…calibrate again

The link you’ve posted describes a similar problem, and suggests using ATC_THR_MIX_MAX to fix it.

The flight controller is putting too much priority on maintaining the altitude and dropping the motor output to the point where there is not enough thrust to stabilize anymore.

You can see this happening in the log when the oscillation starts and the motor PWM outputs drop to minimum:

There is nothing in the release notes for AC3.5 to suggest it will fix this problem.

@Jose_V_Grau It’s up to you whether you try this setting to see if it helps. I am suggesting this setting based on my own experience and the recommended settings from the Copter documentation.

Another thought. When the autotune completes, you never actually try the new PIDs, so when you flew back and then crashed, you were still flying on the original PID settings, so we actually don’t know if this is simply a problem with the original PID settings you were using.

From autotune documentation:

When the tune completes the copter will change back to the original PID gains.
Put the ch7/ch8 switch into the LOW position then back to the HIGH position to test the tuned PID gains.
Put the ch7/ch8 switch into the LOW position to fly using the original PID gains.
If you are happy with the autotuned PID gains, leave the ch7/ch8 switch in the HIGH position, land and disarm to save the PIDs permanently.

If you DO NOT like the new PIDS, switch ch7/ch8 LOW to return to the original PIDs. The gains will not be saved when you disarm.

Emin I appreciate your advice, and I will definetly try the newer BLHeli firmware. Honestly the only reason I was running 13.2 was because with that version i could still disable voltage cutoff. Since I’m flying with Lithium Ion batteries which I can safely discharge down to 18volts. On later firmware version that option disappeared .

Juzzle, actually in this case I was flying with new PID’s since I was able to successfully Autotune the Pitch and Roll axis separetly. The crash happened right after finishing Autotune the Yaw axis. I got the completion beep and while flying back to my location for a land, when I released the sticks to come to a stop/hover , the quad started a violent wobble which progressively got worst until it flipped and crash.

Update: Well today I’ve was able to successfully autotune my Aerobros T41 / Pixhawk 2.1. Following my last attempt which ended in a crash, I think I’ve finally resolve the stability issues I was having. After having to replace one of the motors and two esc’s I re-flashed the esc’s with the latest BLHeli firmware, I also enabled the “damp light” feature. Damped light at least in my eyes allowed for a much quicker response from the motors thus allowing for a more precise control. In addition to that I also increased the ATC_THR_MIX_MAX to 0.09 ass recommended by the Autotune instructions. After those changes I ended up with a very stable quad and the following PIDS:

However I do have one question; originally I was running BLHeli 13.2 because on that firmware version I could disabled the voltage cutoff. Since Im flying with Lithium Ion batteries I needed to be able to do that. On the latest BLHeli version however that option is no longer available. so Im not sure if the new firmware will still allow to discharge my battery down to 18.0 volts.

Damped light do not allow a much quicker response, it does what I explained you .