Servers by jDrones

New Airspeed sensor (MS5525) for ArduPlane 3.8

Make sure your sensor is shielded from sunlight. I’m seeing less than 1 m/sec orientation sensitivity in my Convergence as documented in my PR linked by Rolf above:

I have covered the sensor, but still AS changes when i nose Up the Cube. i tried with old airspeed sensor, works perfectly

I suppose the orientation sensitivity might vary across sensors; there doesn’t seem to be any spec relating to that. Does the old airspeed sensor read accurately at such low airspeeds? What are the stall and cruise airspeeds for your airframe?

old airspeed sensor MS 4525 works accurately. stall speed around 8 m/s cruise 12m/s

this new airspeed sensor very sensitive, even when i touch to plastic cover pressure changes.
I am thinking maybe AS changes when i rotate because of momentum something inside?

I flew with this airspeed, airplane doesnt handle altitude well, it lose altitude then climbe higer then lose altitude , i saw on blog other people also had this problem… are you getting any problem on flight?

The differential pressure at 8 m/sec is roughly 32 Pascals, at 2 m/sec it is about 2 Pascals, so the maximum effect of your observed sensitivity will be on the order of 0.5 m/sec near stall speed and 0.2 m/sec at cruise speed.

That’s assuming my calculations are correct. The relevant code is here:

Great, great news! Thanks for the report. Let me know if you need anything. :wink:

It’s great.
I hope i can purchase one. i wish to.

So you did not need to use any offset on your own?

I just cannot get min to zero out.
It is jumping 1-8km/h

My biggest concern is still if the original issue is fixed. That is if pre-flight calibration messes it up or not.

@pompecukor I haven’t seen any problems with preflight cal for the 3 MS5525s I’ve tested. I just boot up, uncover the pitot tube and fly. I’m flying my sbus1_hal PR branch on the Convergence, which is based on a recent version of master:

Ok, I just upgraded the firmware to 3.8.2, then checked the variance after rebooting, and with pitot tube covered it was reading 0.0 to 0.2 when powering the pixhawk only by USB. Then I took it out to the field for a test flight, and after powering up with the pitot tube covered, the variance was rapidly fluctuating from 0.0 - 5.5 m/s. I cycled the power a second time, and still the same variance, up to 5.5m/s, so I’m wondering if something else is causing this?

The old sensor was mounted in the same location as the MS5525, its an enclosed side bay, so no exposure to sunlight, only difference in this case is powering a Pixhawk 2.1 via USB or a Mauch Hall Sensor via 6S battery. The old sensor never varied more than 2.0m/s

Because of this, as I did before, I manually adjusted the offset value down until the airspeed varied from 0.0 - 0.2, and then did a quick test flight, and airpseed readings were very good, so I think until we can determine a fix for this, I’ll probably be best off disabling the self-calibration, and just use a fixed offset that I know works in the mean time.

Just ran an additional test indoors before I head out to the field this time, and this time powered everything up with a 6S battery, and variance is only 0.0 - 1.5m/s, cycled the power several times and compared to powering with USB only and both have very comparable readings, so I don’t think it has anything to do with how the Pixhawk is powered. Will do some more test flights this weekend and see if I’m getting any more large variances like I saw yesterday and will post the results, still not sure what caused the 5.5m/s variance.

For my fixed wings, a 5.5m/s variance could definitely cause a stall, up to 2.0m/s variance is acceptable and safe.

Keep in mind that, since airspeed is proportional to the square root of differential pressure, an average reading of 2.75 m/sec (assuming the average is midway between 0 and 5.5) at zero airspeed corresponds to a pressure offset of about 3.8 Pascals (with airspeed ratio=2).

With that offset, if your measured cruise speed is 12 m/sec, the corresponding diff. pressure is 72 Pascals, and the actual diff. pressure would be about 68 Pascals. That corresponds to an actual airspeed of 11.7 m/sec; the actual measurement error is only 0.3 m/sec not 2.75 m/sec.

But, of course, if the auto-offset calibration is behaving inconsistently we need to determine why that is happening. I haven’t been able to reproduce that problem with my PixRacer, and don’t have a Pixhawk 2.1 to test with.

Did a lot of fligth/field test a couple of days ago.
I can certainly confirm that is is very inconsistent.
manual setting is fine, but as soon as auto (pre-flight) offset calibration is used, then it gets messed up.

For me (that maidens a new UAV every week on average) another issue with this is that the finding the initial ration is hard, with the offset messing about to much. The is using autocall and in flight as before is not longer so straig forward as they are related to the offset which is not set correctly and I cannot know the correct value before I am able to use autocal loiter in flight.

With 4525DO is was straight forward. Even though that as other have mentioned has more noise.

I have just installed on e of these with a Pixhawk 2 and the readings are very erratic. Typically the airspeed fluctuates between 6 and 12m/s in dead air and after calibration. I did change the ARSPD_TYPE to 3 in the parameters and also had to change the Bus setting to 0 to get it to work.

Any thoughts?

What exact version of ArduPlane are you testing with? 3.8.x?

I am not sure who the question was ment for, but I don’t think there is a version 8.3.x…
You probably ment 3.8.x :wink:
I am on 3.8.2 and I am guessing so is Jacues.

My apologies, you are correct about my typo.

As far as I can tell, you can expect Mark’s airspeed fixes to be included in the Plane 3.8.3.

Yes, I’m on 3.8.2 on all 5 of my fixed wing aircraft. I have been really struggling with the MS5525, tried it on 3 different aircraft but all seem to have the same problem in that the airspeed slowly creeps up to around 4 or 5 m/sec after a few minutes. This is with stable temperature and no sunlight on the sensor. I have gone back to normal digital sensors, as I can’t risk a stall with expensive equipment on board.


Servers by jDrones