Servers by jDrones

New Airspeed sensor (MS5525) for ArduPlane 3.8

I am not sure who the question was ment for, but I don’t think there is a version 8.3.x…
You probably ment 3.8.x :wink:
I am on 3.8.2 and I am guessing so is Jacues.

My apologies, you are correct about my typo.

As far as I can tell, you can expect Mark’s airspeed fixes to be included in the Plane 3.8.3.

Yes, I’m on 3.8.2 on all 5 of my fixed wing aircraft. I have been really struggling with the MS5525, tried it on 3 different aircraft but all seem to have the same problem in that the airspeed slowly creeps up to around 4 or 5 m/sec after a few minutes. This is with stable temperature and no sunlight on the sensor. I have gone back to normal digital sensors, as I can’t risk a stall with expensive equipment on board.


I started today to use the new MS5525 bought from Mrobotics.

First I tried with value 2 for ARSPD_TUBE_ORDER, immediately after Preflight calibration read value was 0 but after a couple of minutes it went to 16 ms even if the pitot tube was covered.

Then I connected the tube in the right order (they were switched) and used 0 for ARSPD_TUBE_ORDER.
Now the read airspeed is contantly between 0 and 0,4 ms


This new airspeed sensor is not good at all, it has bad static reading and has some lag in sensor reading , i am not sure, i have tested 2 differen MS5525 airspeed senosr i had altitude problem and airspeed problem. airplane even stalled, i switched to manual and safely landed the plane, then changed to MS4525 , plane flies great. even though i tried with V3.8.4 which has good airspeed calibration. i tried on ground , it calibrates perfect, but does give correct vlues on flight.

@Artem_Skorsky - Sorry for the trouble.

You should contact mRobotics support because your results are almost completely opposite to all of the feedback I have gotten.

I havent use the Ms5525 module from mrobotics, i made my own board with 5525 sensor, on ground works perfect, i have made many flights, not 1-2 , finaly i found that problom comes from airspeed, even i disable airspeed in parameters, stil APM use static port to calculate altitude, and i got wrong flight altitude even it was disabled on soft. then i removed airspeed i flew with 4525 works fine, with GPS speed , flies fine. I also considred sensor might be damaged, but i changed sensor to new one, i got the same bad result.

This is tough to diagnose given the variables. I can only assure to you that many users are using the MS5525 and the results are almost always superior to the older MS4525.

I tested MS5525 sensor about two weeks ago, I found MS5525‘s temperature was always incorrect, not only never changed but also at high temp(about 460 ℃)

I decided to try after reading some good comments about this sensor, but result not satisfied as MS4525 sensor. also anybody can post to compare altitude difference between GPS altitude and baro altitude. on my tests , GPS altitude close with baro altitude when MS4525 sensor on drone. i switched to ms5525 GPS altitude correct but baro altitude way different .

@Artem_Skorsky I’m afraid I’m not quite following you. ArduPilot only supports the MS4525 and MS5525 sensors as differential pressure sensors. There is no way to read an altitude from the airspeed sensor, and it will not be used for that. The static port on your pitot static system is only used to derive an airspeed reading, unless you have your own custom tubing that then connects the static port to the baro sensor on your flight board.

What board are you attempting to fly with, and what accessories are plugged in where?


After two months of use and dozens of flights I can confirm that the MS5525 airspeed sensor from Mrobotics is working great , I never had any issue.

The only “problem” is when I forget to remove the protective cap from the Pitot tube at take off.
While in FBWA the plane has a very large turn radius, in Auto mode , the plane immediately try to deep dive to find speed and I do not suggest to anyone the experience.
Of course it is not depending by the sensor type but rather by my stupidity.


as i remeber when airspeed is connected , ardupilot code use baro data from static port of airspeed sensor.

Hi , could you please share one of your log file with me, i would like to compare your airspeed graph with my graps to see, if the problem came from my board

seems i am the only one getting problem with thsi sensor . i made this shematics, am i missing something?

@Artem_Skorsky No. We don’t use baro data from the static port of the airspeed sensor as there is no data available. The MS5525DSO is a differential pressure sensor. It can not provide you with an absolute pressure rating on either of the ports.

I seem to be having a slight problem with the MS5525DO from mRobotics. It seems to need a “warm-up” just like the older sensors. I thought that it was temperature-compensated, but it appears that there are some other factors at play.

My first flights on a battery pack take place approximately 10 minutes after cold booting from 0-degrees C. After the 10 minutes, I run a preflight calibration in misison planner with the pitot tube covered. This sets the 0 airspeed properly. After about 30 minutes or more of flying (in 0-degrees C), I notice that the indicated airspeed creeps up. When I land, and re-cover the pitot tube, I notice about 4m/s positive airspeed. Re-preflight-calibrating brings the value back down to 0, and then the rest of the flights are good and calibrated properly - both 0 and actual airspeed.

That’s true. Here is a screenshot compared to the Groundspeed and the second sensor (SPD33):

I am giving up on this for at least 1 year. It has been nothing but headache for me. Any time I hear that "it’s fixed’ I go ahead and install it on the “next” build. However there is always troubles.
Never had a single issue with 4525 in all my experience.

Been waiting for you to bless this sensor! So I will wait a bit longer.

Servers by jDrones