New Airspeed sensor (MS5525) for ArduPlane 3.8

With lowest shipping cost ($15.50) i will have to pay german tax (19%) on the total costs.

1 Like

Looking at the datasheet it seems like a good sensor! How are your tests with them going? Do you have test data? The company I work for is looking for a new Airspeed sensor to follow the change to Pixhawk2, and this seems like a nice option. If it goes well, we plan to buy a batch this month.

1 Like

It has been working well. We have sold a few of them and no complains so far. =)

Sorry to hear that. Please, next time let me know so we can work out a better price by quoting shipping manually and also give you other trade options.


Thanks Jordi,

the MS5525 arrived today (German customs took 14 days to calculate € 9.86 and to fill in a large form - :unamused: ). The sensor and pitot tube will be installed in our VTOL. I will report.

Best regards

1 Like

The noise is much lower than the noise of the 4525DO:


Regards Rolf

1 Like

Thanks for sharing your results! Awesome. I’m releasing more sensors soon, new magnetometer as well. Please let me know if you are interested. Please PM for developer/tester discount.

I just received the new MS5525 airspeed sensor and so far I can’t get it to work on the 2.1. I’m running 3.8rc5 and have set the TYPE to 3 and Bus to 1. The airspeed is stuck on 39 and altitude is on zero. When I blow on the pitot tube there is no change. I have two of the MS5525 and they both do the same thing so there’s something I’m missing. Any ideas? Also I get a Airspeed Sensor un-healty message on start-up.

Is ARSPD_PIN set correct ? ARSPD_PIN = 65 for Pixhawk 1
No idea if this is identical for 2.1

Hi Rolf, Yes, The ARSPD_PIN is Set to 65

I was just looking at the Libraries and the airspeed library has the driver for the MS5525 airspeed sensor but the Baro library doesn’t have a driver for the MS5525. It’s been a very long time since I was working with the development but I think that is why I’m seeing airspeed but no altitude.


I recommend not blowing with your mouth the sensor, we noticed is very sensible to humidity. You can press the inlet with your finger and you will see good airspeed indication or use a fan/blower.



What do we do if we have high humidity in our area? will it work?

HI Jordi,

Are you planning to add compass and magnetometer sensors inside the same airspeed board?

Could you get it to work? We are having the same problem. Changed both settings but no airspeed reading

I have the same problem, couldn’t get my existing airspeed sensor to work with Pixhawk 2, so just tried the new MS5525 today, can’t seem to get any readings at all, have the ARSPD_TYPE = 3 and ARSPD_BUS = 1. I am connecting to the I2C 2 port on the Pixhawk 2, and I’m running 3.8.0 beta6.

Has anyone successfully got an airspeed sensor working with the Pixhawk 2 yet?

@223Wylde did you try ARSPD_BUS 0 ?

Yes, finally got it working on ARSPD_BUS 0, still have some issues though, it worked awesome at first, but now seems to drift from zero to about 6-8m/s after the initial calibration. Maybe I just have a bad sensor? I’ll contact Jordi to see if he has any ideas, tried switching the tubes and keying-in manual offsets, nothing seems to help.

  • Jeff

@223Wylde Is the sensor exposed to sunlight? (And even if it’s not directly exposed can you notice a difference in reading by shading it’s installed location from light?)

Now you cough my attention (deficit)! haha. Ok, it seems like you might have an unusual situation that we should explore more to determine if the sensor is dying and why. Please send me all the data you can, logs, pictures, how you mount it, anything that could help us investigate this, please. If we are unable to solve it, we will replace it and test it ourselves.