Mission Planner Joystick: Futaba 14SG USB Help

Hello All,

Good evening. I need some help with my Futaba 14SG. RF wise, it works completely with my vehicle; however, I also want to be able to use USB capability. I have a Phoenix RC dongle and can connect to the Futaba no problem through the trainer port. On the Futaba, I have it set to FHSS and the trainer port is active. In Mission Planner, the joystick will not read all the channels like it would on a Taranis. I can program the first four channels and one switch, and no other switches. The computer see the Futaba and have tried working the game controller setup on the windows computer. Anyone know the possible issue or could help?

1 Like

I have the same problem as you … I have a futaba 14sg and I also have the phoenix rc simulator interface … that I would like to use to be able to connect to the mission planner so that I can use my parameters of my drones … but I can’t have the futaba recognized by the mission planner as josctik … even though I have set it up as you did in FHSS … I was wondering if you could help me.
Thank you

I’ve been struggling with all kinds of joystick interfaces lately and I found out a couple of things:

  1. Most RC to Joystick interfaces can only handle 4-6 channels. The majority only 4.

  2. The best solution is a Betaflight controller configured as Joystick interface. It handles all channels correctly.

  3. Another possibility is to use an Arduino Teensy 3.2 as a Joystick interface. There I managed to get 6 analog channels and 2 switches.

  4. I’ve tried to make a Joystick interface with an arduino nano, but that failed.

You can check this as well:


I bought this card as indicated by the site " KINGKONG/LDARC RX800-PRO 2.4G 8CH S-FHSS Digital Receiver for Futaba 14SG 16SZ 18SZ" but you don’t know how to make it work … how to connect it …

I don’t think this is a Joystick receiver.