Mac Error: Cannot open serial port, please make sure you have your radio connected

Quick Question: Are you using a USB cable or a radio modem?

Radio Modem, I bought the APM kit from Ebay here -

Also, should I have to install a package called QT…?

These 2 errors had me searching and I found the app above.

[20170215 19:07:04.679 ERROR] - serial connection: error QSerialPort::SerialPortError(NoError)
[20170215 19:07:04.681 ERROR] - serial connection: error QSerialPort::SerialPortError(DeviceNotFoundError)

Also, I am seeing a warning in the APM log file

“[20170215 19:05:26.416 WARN ] - You might be loading two sets of Qt binaries into the same process. Check that all plugins are compiled against the right Qt binaries. Export DYLD_PRINT_LIBRARIES=1 and check that only one set of binaries are being loaded.”

I am going to change my efforts over to a Windows machine. I will update you, thanks!

I think you have played around way too much with the drivers.

On Mac it’s load driver and run program.
I am running the same Mac OS version without issues.

So weird… and maybe I have. I can try a new user account and see if it works their. Did you disable the App Drive first?

I got it to work in no time on a windows machine.

Hi Wbeckwith,

I have had a similar problem and wonder if you ever managed to resolve it for your mac or whether you just use your PC now?

I get the feeling my trouble is that my mac doesn’t register my radio module when connected by usb (as per photo below). I’ve tried different cables, reloaded all the same drivers as you and still nothing.

The only device options I get in APM Planner are as follows:

Any advice would be gratefully received!

Are you using a powered hub?
Have you tried different USB ports.
If it is not registering on the USB Device tree it looks to be a hardware issue.
Have you loaded the drivers?

it’s probably using a different USB chip than the FTDI one. I think there is a Silicon Labs (SI) version of the radio with USB. Try looking for that driver

I will be honest, I worked in this for weeks and then changed over to a windows machine. Again, I tried for a few weeks to get it to work. I got no GPS signal and no communication, well sometimes on the WIN8 machine it would work but it is very inconsistent.

I bailed on the APM and went with a NAZA M Lite.

Hope you can have better luck!

Sorry to not be much more help.

If you have faulty HW from unreliable source, this unfortunately can be the outcome. Bt it’s not an issue with ardupilot. It would require you to contact the HW manufacturer for a replacement and assistance.

Bill, I totally agree, I think the ArduPilot system is amazing - if I could only get it to work. I am not sure if it was my HW or my trying so many things to get it to work across a Mac and Windows laptops. The system looked more impressive to me that the Naza V2 I have on my other Quad. I really wish the system worked that I had. I may try it again with a APM down the road.

But I was not claiming my issues on the APM…

The support on this site is amazing as well… I just have limited time and was getting frustrated.

Philip your getting more connection types than I was. I work for Apple, I would say try this.

Setup a new user account on the Mac. This will allow for a separate set of SW / drivers / etc.

Then follow the instructions to the letter. Only install the USB drivers they mention.

But using a new user account would also stop any 3rd party drivers from conflicting with this setup too.

Lastly, I dd read about a Apple USB Kext file that had to be disabled to get the right one to work. I would inquire from folks here if thats still the case. I did that as well, had to login as the root user to do it, and it did not fix my issue (telemetry communication through USB / GPS location). However, mine never communicated on the windows machine either. So… I never was sure if that was an issue or not for troubleshooting purposes.

If you have any Mac issues I am your guy, feel free to reach out.

APM… sorry defer to the folks here, they are the experts :slight_smile:

Best of luck Philip, Please let me know what you find out, I really do love the APM interface and features. I would LOVE to move back to one if I can get it to work. I just need to get one quad in the air to have a win and then I can spend more time troubleshooting a build.

Best of luck man!

For driver support the FTDI site is what I followed when I had comms issues

There is also a page regarding the new Apple FTDI drivers and how to get around them or add to them.

Thanks for your reply’s guys! I am sorry I haven’t replied sooner, I must turn on my notifications because i didn’t think anyone had responded!

So it now works but you’ll be interested to learn I didn’t change a thing. I just went about having another go at tackling it yesterday and the “cu.usbserial…” option has suddenly become an option and now works when i select it.

I had tried different usb ports and cables before yesterday and nothing made a difference, i even restarted the computer and it didn’t help on saturday. So I have come to no conclusions as to why it now works, all i can say is that it does!

The next problem to overcome now, is the very limited options I have in APM planner on my mac! Its almost like the developers don’t like mac 's :wink:

Thanks again for your fast responses guys!

The options I now have for your reference

Thats awesome news !!

Can you post an image of the area in Planner that your not seeing options you think you should be?

The options you can see is the result of me right clicking on the map!

The Camera actions are also missing!?

I have created a new thread for my latest problems: Limited Flight planning options on APM Planner 2.0.24 for MAC

@wbeckwith I thought you might find this document helpful if you haven’t already found it on the FTDI web site.

When I started having connection problems (too many drivers loaded onto one another over time) this sorted it all out and I haven’t had to touch a thing since.

AN_134_FTDI_Drivers_Installation_Guide_for_MAC_OSX.pdf (1.1 MB)