Loiter mode keeps throttle center, but copter still rises

Hello,I was using Copter 4.1.1. This was my first flight, and I took off in Loiter mode, kept the throttle in the middle, but copter still went up.But later it stays at a steady height in RTL mode.How can I find the problem? Thank you for Everyone’s help.

This is the bin file


That is so wierd.
Desired altitude is rising !! even though c3 is 1501

I am not able to peek at your log, but whoever does, may find the attached log interesting too:
It’s a Solo with AC4.1.1 and laser rangefinder. - doing exactly what you describe, climbing uncommanded now-and-then.
Some may say it could be attributed to Z vibrations, but such levels were not an issue before… if so, AC must have become more sensitive to that ?

Yea, the rangefinder data looks bad. Z-vibes are high. And you should be using EKF3 not 2. You are also missing some Initial Tuning parameters and haven’t configure the Dynamic Notch Filter.

There is a lot more into Desired Altitude than just throttle position…

@dkemxr what would you say is the issue in my case? (next test will be on 4.1.3)
Still, same damping and light props as always on Solo, and good lidar data. No crazy vibrations.

Puzzling. Rangefinder seems to be working well and as you say the Vibes are not terrible. I’m not sure what the “Sensor State” logged data is. It show it dropping from 4 to 1 somewhat randomly but because I don’t know it’s meaning not sure if it’s related.

@dkemxr I’m glad you too find it odd.
the RFND.Stat varies between 4(Good) and 1(No data) should not be the reason, as it’s not uncommon for a lidar not to get a return.

Still… it does correlate rather oddly.

Who do you think we can invite to have an opinion about this? (I see nothing in the changelog that would suggest this is an issue of the past.)

I might be wrong here, but isn’t that what’s been fixed since the 4.1.2 release?

@Karl_Schoelpple I checked the release notes for 4.1.2…4.1.3 before posting, (now 4.1.4) - and could not see anything about such an issue.

He’s talking about this fix in 4.1.2:
f) Surface tracking fix if rangefinder glitches.

Although I’m not sure I see Dalt being reset when your glitches occur. Could be related though. In any case 4.1.4 is Stable so update and try it out.

Maybe this has to do with MOT_THST_HOVER is set too high? It looks like MOT_THST_HOVER is not being actively adjusted - even tho MOT_HOVER_LEARN is set to 2.

Try lowering MOT_THST_HOVER a little bit then takeoff and hover in Alt-Hold and Loiter for a little bit.

Also - just another point of concern. Your autopilot voltage is reading around 4.9V during flight and sags heavily upon takeoff. To mitigate the risk of autopilot power failure - this voltage should remain above 5V throughout all flight. Also - try to make it uncoupled from aircraft power draw so sharp spikes in current draw don’t cause the autopilot to brown out.

@manavgandhi17 Thank you.
Yes, the Solo may have a slightly low voltage, but it does have more than one source.
Good point about the “ground tracking” … will absolutely check again once the weather permits.

As for MOT_THST_HOVER - that should not be able to produce such effect, when flying in an updraft, I’ve never seen uncommanded climb over several second just because the throttle demand is reduced, - just like when you drop some load.

Strangely, I saw similar issue long ago, probably last summer. When I leave quad copter in hover learn, I saw similar altitude raise. Probably I can’t find the corresponding flight logs, but I managed to solve this disabling hover learn and setting the paremeter to some reasonable value.
I think this was due to my quad is really overpowered (thrust to weight ratio was almost 8-9).
It wasn’t like skyrocketing but I was seeing that the altitude was raising.

@Mustafa_Gokce point taken, I’ll try with current release, and disable autolearn if the issue is still there.

Hi @Andre-K,

Any idea what RFND.Stat = 3 represents?

Can’t seem to find any documentation on this.