Loading custom firmware with Mission Planner Simulation Feature

Hi all,

I am experimenting with a RealFlight8 + Ground Control setup, so far we have been playing with both Mission Planner and Mavproxy and both are working great so far.

Now, we plan to use RF8 to test custom firmware (compiled with waf). I have verified that Mavproxy + SITL are capable of loading custom firmware into RF8.

Here is my question: Is Mission Planner’s Simulation Feature capable of loading custom firmware into RF8? Currently the feature loads the latest firmware (Plane 3.9 beta), but the GUI has no option of selecting custom firmware.

Things I have tried:

  • Replace the ArduPlane sketch created by Mission Planner’s Simulation Feature (found in the “Mission Planner” folder) with my own custom firmware compiled by waf. This doesn’t work as Mission Planner simply overrides the custom sketch with a new default sketch when the simulation is started.
  • Modify the sim_vehicle.py script (Created by Mission Planner upon simulation startupm also found in the “Mission Planner” folder) to disable rebuilding. This also fails as the script is also overwritten on startup.

There is insufficient documentation on how to use MP’s simulation, as compared to SITL + Mavproxy (http://ardupilot.org/planner/docs/mission-planner-simulation.html and http://ardupilot.org/dev/docs/sitl-with-realflight.html) thus I do not know how to proceed.

I know it is possible to do it with Mavproxy, and then connect it to RF8 and Mission Planner. However, I am curious to find out whether it is possible to load custom firmware with Mission Planner’s simulation feature alone.

Anyone out there able to help?

1 Like

Hi, may I ask if this problem is solved?
Encountering same problem here…

I’ve fallen back to using MavProxy + SITL/RF8.

If you really need Mission Planner, then your best bet is to connect SITL/RF8 to MavProxy, then rebroadcast from MavProxy to Mission Planner (through a VM, LAN network, or whatever setup you prefer)

1 Like

Missing planner uses cygwin compiled exes for sitl. You would need to compile it yourself to use any custom changes


Feature request. Could a drop down be added to use previous AP SITL builds? Right now it’s a little frustrating to be forced to use cygwin to get the current release version to run in SITL.

Hi Michael,

Are there instructions on how to compile this .exe file? I assume I then just replace the .exe already existing in my sitl folder on mission planner? I also want to test my custom firmware in MP.


Any update on this? I’m trying to use MissionPlanner+SITL+Realflight as a training tool, and having the SITL firmware version not matching the aircraft firmware version I use is highly frustrating when changes appear in the latest firmware. I’d like to avoid complicated things like MavProxy and Cygwin, if possible, those provide their own headaches and are difficult to deploy to systems already in the field. Is there any way I can just get an older ArduPlane.exe file from somewhere, paste it in the SITL folder, and prevent MissionPlanner from overwriting it?
Otherwise, I’d like to parrot TunaLobster’s request, being unable to simulate specific versions of Arduplane really limits the usability of SITL for troubleshooting, pre-flight mission testing, or otherwise.

Hi james, have you been able to find a way to specify what plane firmware sitl uses?


@lowlyelevated @Shef I posted on this thread. hopefully you find it helpful

Thanks Bill, it is quite helpful.