Servers by jDrones

I2C Maxbotix range finder on Pixracer

pixracer
rangefinder

(ppoirier) #41

No news yet, here is what I wrote here: https://gitter.im/ArduPilot/MissionPlanner
patrickpoirier51 @patrickpoirier51 sept. 26 07:48
@meee1 can you take a look at this issue = No rangefinder on display when using PixRacer + rangeFinder on UDP (works with Serial) I2C Maxbotix range finder on Pixracer

But @meee1 hs not looked at it yet.

You can open an issue , it might help


(chris rey) #42

thanks, will try, nice we, Chris


(ppoirier) #43

@chris661
I updated the ESP8266 firmware and it resolved the issue.
Try it : https://pixhawk.org/peripherals/8266


(chris rey) #44

great, will try, with version 1.1.1 right? thanks again, Chris


(chris rey) #45

sorry for long time non answering, yes it solved my problem, thanks


(chris rey) #46

hi, PX4FLOW 2.1, any significant improvement from 1.3.1? same compatibility? thanks, Chris


(ppoirier) #47

Flying with both, no difference


(chris rey) #49

Always an error message with Bad lidar health, but seems to work fine, look at some posts about that but still the message, any suggestions welcome.


(ppoirier) #50

Just disable the rangefinder in prearm check


(chris rey) #51

Sorry, in flight data pre flight? Couldn’t find the parameter.If you give me the parameter name I can look for in full parameter list?


(chris rey) #52

I couldn’t see the rangefinder check box. Is there another way to disable it? Thanks.


(ppoirier) #53

Yes it is not specifically described as rengefinder == Uncheck Parameters


(chris rey) #54

so I uncheck All and check the other one except parameters, right?


(ppoirier) #55

Yes you select the options you want from the menu… it is ‘‘À la carte’’ :wink:


(chris rey) #56

Très bien! :grin: But I think Parameters is not explicit enough, can I suggest someone from ardupilot to modify this parameter name? Or maybe to split it in other more understandable options? Like Range Finder, Optical flow, etc. because you know, in 2 months I will have forgotten this :worried:


(chris rey) #57

Maxbotix definitively not reliable for outside. Try original and copy, both are unable to report alt values above 2 meters for outside. And then, when I tried a mission in terrain mode, with range finder activated (in my case: RNGFND_TYPE = 2), if the drone goes above 2 or 3 meters, it continues to climb (even above geo fence limit) and even RTL doesn’t work, it happens 3 times and I had to land in stabilize mode. For me it’s a bug, after RNGFND_MAX_CM is reached, the drone altitude should be managed by the barometer, but this is not the case and causes a Fly away if you do not take the hand again.
I had this problem only in Terrain mode mission, the range finder seems to work better (in coorelation with baro) in Relative alt mode. Stranger Things…


(ppoirier) #58

ok good to know, I will resume outside fly in a few weeks and certainly report back on this issue.


(chris rey) #59

Will order TFMini, follow your blog procedure and give a try…


(chris rey) #60

printscreen difference alt. baro range finder.