Helicopter cannot run in the SITL

I cloned the latest Ardupilot software and run it on the SITL simulator. Everything works find and I can see that the default setting is a quad-copter because in “config.h” FRAME_CONFIG is defines to be MULTICOPTER_FRAME.
However, when I changed FRAME_CONFIG to be HELI_FRAME and rebuilt the software, it cannot run on the simulator any more. The Console displayed UNKNOWN mode. Does that mean the simulator only works for quad-copter?

Many thanks.


What command do you use ?
using sim_vehicle.py -v ArduCopter -f heli --console --map -m --mav10 -w seems to working fine, and loading the heli simulator

Many thanks for the suggestion. I tried it and the simulator can be launched correctly. However, the ARM icon is always red on the Console after I use command “arm throttle”. So the helicopter cannot take off. Can you advise how to solve the problem?

I never use an Heli, using, for the “APM: PreArm: Motor Interlock Enabled” message, you can use :

param set CH8_OPT 32
rc 8 1000
arm throttle

set CH8_OPT 32 <— assign interlock function to channel 8
rc 8 1000 <— remove the interlock
But after I don’t know!

Many thanks for the suggestion. I tried the commands and helicopter can be armed. However when I issue takeoff command “e.g., I used takeoff 20”, the helicopter does not take off and it becomes disarmed after a few seconds. Any further suggestions? Many thanks indeed.

Any solution? I cannot run sim_vehicle with heli too

where do we input the above commands?

@selehadin-cyber In MavProxy window.

Check this. arducopter-heli in sitl cann't takeoff?