EKF ground mag anomaly - has anyone heard of it?

I’m still having this lean to left with first forward flight problem.

I’m using Pixhawk4 mini by holy bro.

I got 2 craft working fine but 3rd one leans left, then self corrects after about 10 secs of flight.

On a 4th craft I moved the GPS compass far forward as possible, but was then middle of 2 motots. This helped for that craft.

I tried using this as a solution on a fifth craft and it did not work.

The final working solution was put on a dji naza m2, and that solved all the problems.

I’ve gone from a a cheap version of pixhawk, to the most expensive our project can afford.

I’m of the opinion that there is some firmware updating required that needs to resolve these issues.

I spend a whole day or more trying to solve this lean to left issue on a craft with very little success.

I take a naza m2, and 15 mins later it is being sent to customer.

My frustration level is beyond what I can bear with pixhawk consistency.
I’ll be continuing the learning process because my customers really want the Pixhawk4 telemetry options, but I’m not able to sell any Drones when I spend days at a time on one craft.
Very disdapointing for me at moment, but my business has to move on.

If anyonw has had this leaning issue on first forward flight, and you have any practical solution to implement, please share it as it will take my life out of a living drone hell.
Thx in advance.
Gary

post your log, I will look at it.

In my case, we were mounting the Here3 without a stand, and the power wires of drone were interfering with the compass, causing an incorrect yaw reset when taking a flight, After changing the Compass Position, and increasing the stand height to move away from power wires, we were finally able to resolve the issue

It seems it’s quite common issue. Is it still relevant for the next versions?

This requires an hardware fix. It can not be fixed witjh a software update.

I just had a incident with “EKF3 IMU0 MAG0 ground mag anomaly, yaw re-aligned”. Been flying great for the past week in the same location, flew 5 min prior to this flight fine. Took off in stabilized, switched to loiter and it went crazy hard right then left, i quickly switched back into Althold then stab and it was better. Here are the logs. I’m using the latest Quad 4.1.0 beta-6 load.

File name “EKF3 IMU0 MAG0 ground mag anomaly, yaw re-aligned”

https://drive.google.com/drive/folders/12scDkGkk4NdqlhPVFec8WNyRYSdzVeqG

I have done the compass calibration and after that, I flew my drone once there was no error but after giving the power cycle I took another flight, and in that flight, it was showing ground mag anomaly I haven’t changed anything I just plugged out the battery and plugged. so is there anyone who has any idea why this occurs?