Servers by jDrones

Dual-motor tailsitters

(lorbass) #1262

Large FPV Tailsitter with Skywalker 6.
Successful maiden flight after a long time.

The telemetry reports “Tuning error 0.15”. The compass is not calibrated correct enoughe.
The Pitch Flight is not slow motion, it is so slow even with 30 degrees pitch.

And the docu:

The Parameters.
Nach Test 27.param (16.2 KB)

(Rolf) #1263

Congratulations :trophy:

Thanks for the report and great “PID tuning”-mount. How heavy is the plane? (25 Ampere at 6s ! )


(Jose Ortiz) #1264

WoW very impressive I wish my tailsitter flew that well. mines crashed 4 times out of the 6 times ive flown it. swapped to bigger motors and now it cant fly well at all.

(lorbass) #1265

Thanks for the flowers.
2550 gr without fin and winglets.
But the current measure is not calibrated yet.

(Walter) #1266

Also congratulations!
I am very curious about the consumption in the plane flight.
With a short time to transition and landing (at Belly we calculate 20-25 sec / 30-50 sec) is a long flight time to expect.

(lorbass) #1267

Danke Walter. e-calc berechnet 10 min in Plane Mode bei 50 kmh.
max. Airspeed 77 kmh.

(Henry Wurzburg) #1268

Skimming thought the thread, it seems that most have moved to vector thrust for dual tailsitters…has anyone successfully gotten a plain non-vectored one to fly acceptably? I have my trusty z-84 test platform I use to test AP code changes on or a spare s-800 wing that I would like to try the taillsitter on, but there seems to be little in the way of success stories with non-vectored…any suggestions?

(Peter Hall) #1269

works well until there is some wind, then they have trouble making headway.

The wind blows the wing causing it to lean into the wind so you get more apparent wind, they just sort of fly into the wind and up.

Vectoring also allows you to to belly landings and takeoffs. No reason why none vectored cant work well though there are just some limitations. If you want to convert your z-84 you will have to extend the elevons to be about 1/3 of the span to get enough control.

(Henry Wurzburg) #1270

thanks…vectored s-800 might be possible…z-84 a bit small for the added mechanics I would think…anyone done a 800mm class vectored tailsitter that I could copy the mechanics from?

(Luciano - Tecnodrone) #1271

Hello Friend. I’m a new user on Taisitter.
Would you help me?
I’m using Ardupilot 3.8.5 and did setup exactly as you explained here.

I have already configured the engines with servonn_function in 3 and 4 and also in 5 and 6 using 73 and 74. The elevon is in 1 (77) and 2 (78) with reversion and works perfectly doing the stabilization.

I followed the documentation and started configuring the wing to later enable Q_ENABLE = 1 and I configured AUTO-FBWA-MANUA plane, for Copter only Q_STABILIZE.

My problem is that when you arm the engines, beep, beep, beep without stopping and the motors do not work.

From what I understood it would be to operate in different MHZ 1 and 2 of 3 and 4 or 5 and 6, in the frequencies 40 and 400.

What am I doing wrong?

Is the Servo_MIN _TRIM AND _MAX that I need to configure? How do I do this?

Another question:

In addition Q_FRAME_TYPE = 10 I need to choose the layout of the qudro, being 2 Tailsitter, motors in the wing, I chose 1 = x for Q_FRAME_TYPE. Is this right?

(Luciano - Tecnodrone) #1272

I already found out, I hit min and trim and solved subject for the engines.
Now I need to find out why the engines start at Q_Stabilie and stop.

(David Kaden) #1273

I did.
Lots of Transitions, see description:

After the adding of throttle scaling it somehow messed up my PIDs. Now in the daily (not the beta!) there is the option to set the maximum scaling (Q_tailsit_thscmx)

Not wen your CG is correct, see this loitering in wind:

Limitations of non-vectored:

  • extremely sensitive to the CG. On the one in my video I was testing CG 1 cm more in front and 1cm mor back and this already hat great influence on the hovering in wind. Your cg is correct if the plane can hover against wind with no elevator deflection.
  • I still have no idea how to get it to land in wind without flipping over. Wingtra got this at least in one video, but they had a hard time doing so.
  • instability when you sink in hover. Higher wing + disk loading should improve this.

I just updated to the 3.10 Daily chibios built and also increased the weight on my tailsitter. So it has 1m span, 10 inch props and 1380g AUW. Thats about 50% more weight than in my videos. Hoping for better authority while descending. Will try this soon.

(lorbass) #1274

Hi David,
Congratulation for that perfect tuning, perfect stability, perfect video post processing and amazing low consumption.

(Pavel) #1275


We have tried today 2nd time the Auto mission mode…
And just by luck the plane didn’t land into someone’s property.
How to check what causes that huge course difference?

MP waypoints:
KMZ data:

KMZ data in Google Earth screenshot:

(lorbass) #1276

For me its clear, to much wind (to hear) for Hover Mode.

(David Kaden) #1277

According to log the transition was completed @0:26. So maybe it was just holding the Heading to finalise the transition.
After that and just before you switched to Q_land (why btw?) the estimated airspeed was to low to make any turns, because the plane limits its bank angle then.

Your telem radio noise is way to high and your rssi way to low. I mean, how is that working at all? Fix antennas!

On start your batter voltage is dropping immediately from 12,4V to about 8V. Thats not normal. Are you using low-C 18650 cells?
Anyways you C-Rating is way to low. (so too high internal resistance of your battery)

Had a look at your params, and noticed your flying without Airspeed sensor! “ARSPD_USE = 0” So the plane didn’t know there is wind.
Don’t ever fly planes without airspeed probe, this is absolutely elementary!

I think this is the main cause for the problems you had.


(letpi) #1278

@palm369 point out the q_land order at 30s. This is what your wing tried to do despite the wind until you switched to fbwa. Is the Q_land part of the mission or is it triggered by a failsafe or by yourself ? that’s not clear for me.

(David Kaden) #1279

I think he manually triggered it. Ch8 going high there and he assigned Q_land to a flight mode. I can see no failsafe event in the log.

(Pavel) #1280

I have set the Q_LAND as I noticed, that the plane has started to descent to someones property. Then It took me few horrible seconds to find Q_Stabilize and Q_Loiter to gain the altitude and escape from there. :slight_smile:

(letpi) #1281

I suggest to tune fixed wing mode by performing an autotune and also to tune the navigation controller and only after try again auto mode. From what I can see in your video I think you have ptch2srv_I far too high. I have 0.015 instead of 0.15 value I can see in your parameters. The same for rll2srv_I