Drone reach extreme angles (114°) in brake situations


While testing my drone limits with 3 blades I was experiencing extreme braking maneuvers,
the drone goes 114° while the ANGLE_MAX = 4500, which mean it way over the limit.

As you can see in the picture below, the ATT.DesRoll is doing good with ±45° but the Roll itself goes all the way to that dangerous angle.

it’s happen in AltHold & PosHold (Where braking happen), in Stabilize it’s all good.
In pitch axis the drone reach extreme braking angles as well…

Things i’ve tried :

  • Reducing ANGLE_MAX to 3000 (from 4500), just the same, DesRoll = ±30 but the Roll goes way over than that.

  • Reducing ATC_ACCEL_R_MAX to 25k ( it was around 45k ) -> i’m not satisfied with this,it helped just a little bit and
    the drone felt like there is a delay when I moving the Roll stick.

  • Reducing PHLD_Brake to 5 (from 8), just to check if it helps, but nothing, exactly the same.

After all this I tried to re auto-tune the Roll axis, after the autotune it seems like it helped, but I flew it for just few minutes.
Today I tried again and all back to the same extreme braking maneuvers.

The drone using KDE 4213XF motors (quad) with 50A hobbywing ESCs.

Paramlist after Roll autotune - 3 Blades.param (10.2 KB)

Last flight log - https://drive.google.com/open?id=0B6jjY0zzAT9ZWkNsQ0U3aGRvUEk (couldn’t upload here cause it was too big)

If you have any idea that can help me it will be great.

Thank you in advnace,

Hi Liad,

I had a similar problem with my X8 (see here: X8 Attitude-Altitude conflict... Safe to set MOT_THR_MIX_MAX above 0.9?)

As far as I know, this only happen on large copters, and seems to be because air catches under the props when braking. This causes the copter to climb a little, which the flight controller compensates for by reducing the motor outputs. Motor outputs get so low that there is not enough power to stabilise the attitude.

Try increasing MOT_THR_MIX_MAX to 0.9 to start with.

(If necessary, the value can actually be increased all the way to 2.0 although mission planner will tell you this is out of range.)

Hope this helps you … I’d be interested to hear how you get on with this setting.


Just to echo a bit of what Justin said, increasing the MOT_THR_MIX_MAX parameter helped me with pitch “flaring” as well, and I may be running a quad similar to yours: ~5 kg AUW with KDE 4012XF motors, ~25% hover throttle. I think I have the parameter at 0.8 or so. I did not know that it could be increased past 0.9, though, that is interesting.

Regarding the cause of this behavior, I found that it may be caused by airframe aerodynamics, at least in my case. My drones are dead cat frames and the bottom is a big flat plate. I found that I did not get brake flaring when going backwards, only forwards, and that moving the CG forward reduced it. My hypothesis is that the pitching up to brake caused the airframe to essentially become an airfoil, with a center of lift well ahead of my CG, causing a severe pitch-up moment.

Hi guys,
Its worked !

Today I’ve made the test based on 3 flights -

First flight - I’ve changed ANGLE_MAX to 3000 ( I decided that I don’t need more than that, so from now it’s will be default value with out any relation to if I solve the problem or not ) & I changed the ATC_THR_MIX_MAX to 0.9 as you suggested

Second flight - ATC_THR_MIX_MAX back to 0.5 to ensure this parameter is the one who made the effect.

Third flight - ATC_THR_MIX_MAX = 0.9

Log file of the flights (same log for the 3 of them)

Conclusion -
First flight ( Log lines 0-90000~ ) - Nothing bad happaned, seems like the ATC_THR_MIX_MAX do the job and as you can see in the log, everything is just fine.

Second Flight (Log lines 90000~ - 118400~ ) - I’ve changed the ATC_THR_MIX_MAX to 0.5, the problem back !
risky braking maneuvers again.

Third Flight (Log lines 118400~ until the end ) - ATC_THR_MIX_MAX back to 0.9, everything working good again, I didn’t try more than that for today, I will let you know if I will go over the 0.9.

A thing that I forgot to say, with 2 blades on the same setup it’s never happened to me, it started only with 3 blades,
but you guys solved the problem even without this fact, so seems like its not that matter…

Thank you very much guys !!