Drone ignites Parachute and stops motors while hoovering?

But Jan what about this bit.The PWM for channel 9 in moved rapidly between 1000 and 1500 as you tried to get the OSD back and if the parachute is physically hooked up to that channel ? The on and off values for the chute servo fall in that range. It doesn’t explain that channel 9 out had no value change but it’s the closest I’ve come to seeing something that may relate to the deployment.Maybe worth a bench test to try to replicate the action.

I have allready tried this on the bench yesterdy evening.
The switching is not affecting the parachute and when
i manualy deploy the parachute i have no MAV link message ‘‘Parachute’’.

I didn’t see HUD message “parachute” everytime either last time I tried. 3.5.3 if I remember correctly, last FW two weeks ago anyway.
I tried manual and automatic eject.

I’m out of ideas in this.Hopefully someone brings new steam and we sort this out eventually. Where my research ended for now is:

  • copter didn’t have anything wrong what it comes to flight
  • Pixhawk parameters (1300us High) was not enough to eject in first place
  • CH9 clatter is bugging me but from outside of code it is not possible to say if it can affect AUX1 somehow
  • This particular parachute seems quite special what it comes to connections and functions which means it is complex / special in code too. I would research if there is any change that parachute itself commands Pixhawk to shut motors down when parachute controller decides or is commanded to ignite what ever reason

I noticed there is a parameter which allows logging after disarm. However logfiles will be large which is not normally needed and wanted. After parachute release and crash it might help investigations if logged only then after disarm:

That may be worth doing for testing.But I agree,this is a tricky one.