Copter-4.2.2 released!

sorry. broken signal wire :man_facepalming:


I am able to complete the optical flow Sensor Inflight Calibration.

Now I face preArm check failure due to Rangefinder in 2 even if I disable the preArm check still unable to arm and fly in Loiter mode to test the new FLOW_FnSCALER values.



Thanks for trying the inflight calibration.

If you can move the rangefinder to use the RNGFND1_ parameters then then pre-arm check should pass. I’m sure you know but just in case, use of optical flow requires a rangefinder.

I am afraid I can’t, we are using Hereflow which comes with a built-in rangefinder, and we do not want to use it as it can only reach 3m height.

Ya, experience once bad experience, drone climbs endlessly and hit ceiling. That is why I do not dare to arm and fly with such a rangefinder prearm warning. I do see the Rangefinder2 under Quick UI showing the correct cm.

Hi @Jai.GAY,

ok, so there is another rangefinder besides the Hereflow’s rangefinder right? The Hereflow rangefinder does not need to be RNGFND1_… so set the RNGFND1_TYPE to match the othere (non-Hereflow) rangefinder.

The vehicle shouldn’t fly up endlessly unless an analog rangefinder is being used. With other rangefinders we should be able to detect once the rangefinder is out of range. If you’ve got a link and/or a log file for that endless climb could you provide a link to it?

Second rangefinder we are using LW20

I need to see if I can still get the flight log, last year June.


Great. So you should be able to move all the RNGFND1_xx parameters to RNGFND2_xx and vice-versa.

Thanks, works! I moved all to RNGFND1_xx, do not enable the Hereflow onboard lidar. Rangefinder preArm check enabled and no warning. took off both outdoor and indoor Loiter mode is within expected behaviour and without an external GPS installed.
thank you for the guidance and patience.

Could it be that no Range finder in 1 caused the bouncing flight I had with the super flat indoor surface with SURFTRAK_MODE=1, just curious? I may have to plan time to do a repeat test.
I have concluded that it is not due to skipping of RNGFND1, SURFTRAK_MODE=1 on our super flat blue surface not tracking well.

1 Like

I upgraded to 4.2.2 and noticed that in status window, mag_ofs_x, y & z are shown as zero. Recaliberated the compass twice but still show zero when connected.


Thanks for the report. I’ve reproduced the issue and found that we made this change on purpose to reduce load on the telemetry link. These values were being sent over and over but they hardly ever change and can be seen by looking at the COMPASS_OFSx parameters.

I’ve created an MP issue to remove the display of mag offsets in the status screen.

Hi guys and girls, Just updated from 4.0.7 to 4.2.2 and i have a lot of changes in parameters that i need to set again. But that’s not a big deal. I have problem with camera gimbal option, before it was set to Servo and i used Servo9 function to control Tilt from Channel 6 on transmitter. Now that option is greyed and i cant controll my gimbal.

Just my guess, I never use it before.

Is it the type under 4.2.2 is pointed to none?

Yes and i cant change it. There is no option MNT under full parameters menu.

What Flight Controller?

Update Mission Planner,

Im on latest version, i will try to update to beta now and see if option show

I’ve quickly tested this in the simulator using 4.2.3-rc3 (beta) and it seems to work OK.

As @dkemxr says, it could be that the camera gimbal (aka “mount”) has been disabled on your flight controller so if you could tell us what flight controller you’re using that would be good. As far as I know the mount library should be available on all flight controllers.

I updated MP to latest beta version, still on 4.2.2 FW and no change, still grayed out. I temporary configured servo 9 to RCIN6 and do settings on Taranis so i can fly. Im using Pixhawk 2.4.8 with Tarot gimbal connected only signal wire to AUX on flight controller. That worked like a charm until i updated FW on flight controlled

Are you using the pixhawk1 firmware variant?
Or are you using the pixhawk1-1M firmware variant?

MP detect fmu2, when i try to manual install fmu1 i got error.