Copter 3.5-RC1 Servo Gimbal Not Work

Servo gimbal was perfect with 3.4.5 after flash 3.5-RC1 it’s not work with any aux port. I can control servo from servo tab but gimbal function is not work. My hardware is Pixhawk 2.1

Hello, maybe this will give you some hint
and if you want it would be helpful if you test
obeserve if your board stops working when roll and TX is linked wit your receiver.

@Cipta Thanks for your reply. Actually I know new parameters name but maybe I don’t know some related parameters. Because still I couldn’t fix. Can you run servo gimbal with 3.5rc1?

Hello, yes it worked, but with the fact that the board stopped working when rolling more than 90°and mnt_stab_roll was enabled.
Here are my settings.

Seervox depends on out-pin from board.
Hope that helps

I’m in serious curiosity whats wrong. Because I used same or similar parameters. But still same result.With 3.4.5 it’s ok but with 3.5 I couldn’t run servo gimbal still. I used different servos different boards different aux ports.

??? no idea whats wrong
do you see some chxxout changes in Status tab from MP? SafetySwitch? Passtrough working? External power for Servo? Just some thought - probably you tested already.
good luck

Finally I found the problem. Even without failsafe or pairing RC channels with servos, servo gimbal want to rc in signal. With 3.4.5 servo gimbal can work without rc signal so I always tried to work without RC signal with 3.5 . I tried to read each post but I couldn’t find any detail like that. If someone already wrote this detail before me I am sorry about that. Thanks for your help @Cipta :slight_smile:

For me it’s also new and maybe in the next release it will work again without rc-signal.