Copter-3.5.0-rc7 unexpected crash on ErleBrain

Hi @LanderU

Is this normal?

PS: i typed bt when the firmware crashed

Hi @josepgomes,

you need run the firmware like this:

sudo systemctl stop apm.service
sudo gdb --args ./arducopter -A udp:10.0.0.2:6000

When this message appears (gdb) type r+intro:

(gdb) r

When the firmware crash occurs, type bt.

Regards,

@LanderU

Hi @LanderU,

I was just going to check here the difference on erlebrain3… but there’s no erlebrain3 supported on upstream and checking the docs (http://docs.erlerobotics.com/brains/erle-brain-3/sofware/apm#compile-ardupilot-apm-from-its-s-…) it says to build for erlebrain2. This probably means I can test on my erlebrain2 when I’m back home.

@josepgomes, can you try this? https://github.com/lucasdemarchi/ardupilot/commits/test-stack

You have to wait first until it crashes and then type bt :slight_smile:

Be careful it barely ever crashes in debug mode, so be prepared for a long run. Use micro USB and connect no sensors

But i typed bt when the firmware crashed. In debug mode happens anyway with our copter.

@lucasdemarchi , i don’t know how to test it :neutral_face:

Read Lander instruction above

Sure, but what i don’t know is how to update the new code!

Look up for “compile from source” page. Switch branch to 3.5rc8. change that line and continue to build the binary.
Than execute the binary instead of the arducopter from debian package

Where can i find that branch? I can’t find it on github. Yeap, i believe that i’m a real newbie with this :smile:

Edit: rc8 is the 3.5 branch?

It’s In the tag. I believe
git checkout Copter3.5.0rc8
Or similar

With 3.5rc8 branch cloned and the line deleted that @lucasdemarchi ask to test, all commands worked fine, unless this one: sudo cp ArduCopter.elf ~/

Then i can’t start apm.service, maybe because of this file.

I was following this: http://ardupilot.org/dev/docs/building-for-erle-brain-2.html

lookat the command window output.
usually its called arducopter, built under build/erlebrain2/bin/arducopter

copy paste this instead

Hi @lucasdemarchi,

The difference between Erle-Brain 2 and Erle-Brain 3 is only the raspberry pi, we’re using Raspberry Pi 3 instead of Raspberry Pi 2.

@ppoirier, you’re running the code on Raspberry Pi Zero, right?

Regards,

@LanderU

Last tests were flawlessly performed on a RPI2 compiled as erlebrain2

Hi @ppoirier,

thanks!

@lucasdemarchi, I run the code with your suggestions:

I’m getting the same error.

What OS are you using @ppoirier?

The problem could be in our OS, the plan for this weekend is create a new one.

Regards,

@LanderU

Latest Raspbian jessie

Hi @ppoirier,

nice! thanks for the info :wink:

Regards,

@LanderU

@josepgomes note that in the screenshot you sent the process received a SIGINT, not a SIGSEGV. Do you have anything else running that can potentially send a SIGINT to the process (other than pressing ctrl-c)…?

1 Like