Copter-3.5.0-rc7 is now available for beta testing

Roll autotune in pos hold works well.

1 Like

PixRacer Clone - compass issue
Made Update from 3.4.6 to 3.5.0 rc7 after winter break to 250-racer.
Because 3.5 RC1 does not support my old GPS I ordered a NEO8 GPS - everything works well with this GPS and 3.4.x

The following problems occurred after update:

  • After compass calibration and reboot - cannot arm: compasses inconsistent error
  • With only external compass active it is possible to arm. In 3.4.6 it was possible to get stable compass calibration with 2 compasses.
  • First flight with EKF-Check-2 errors and failsafe in pos-hold. - Checked equipment - made compass calibration
  • Second flight - similar problems: many EKF-Check-2, EKF-Check-0, EKF-Primary-0, EKF-Primary-1 … errors.
    Last flights in march with 3.4.6 always worked without errors.
    2017-05-26 12-48-37.bin (3.7 MB)

Had another go with rc7. No OSD issues and no home reset issues, so either rc7 fixed something or I’ll chalk it up to gremlins.

2 Likes

I didn’t have enought time to check osd well, only plugged one time but I noticed a strange number too, glad to listen that was solved for you,as soon as I have more time I’m going to check better and report if something looks bad. Perhaps gremlings move here :open_mouth:

Have done a few flights with rc7 on 3 different quads - a custom 8S / 800mm enduro machine (underpowered), a 6S/750mm Tarot Peeper with PH2.1/fmu-v3, and because I couldn’t get my racer working did some acro with a broken CX-20 with a Pixhawk in it. That last one was really interesting to fly, as the main pcb is broken off it’s mount, which makes the EKF work for its supper… Logs here: https://drive.google.com/drive/folders/0B21eBYNmOfAKQjV2ZU94S2t1dnc
Had a few little setup issues, but mostly due to APM Planner and QGC not being updated for AC3.5 yet, and a few little tweaks needed in MissionPlanner. Once I downloaded Latest MP was ok for the 3 I flew, but my racer (board type 6) won’t connect now. Suspect it’ll be fine if I do a clean firmware load on it.
Did a bunch of auto on the 8S rig, to test the waypoint yaw behaviour. I think that this is pretty much as personal preference thing, but it does look a little strange.

Same issue, I was able to isolate what happens, to some level.
Upon system restart in old 3.3 and 3.4 you would have all telemetry re-started automatically, with all streams active. Sometimes with some hiccups one would need to go into mission planner and click at ‘enable telemetry’ button in the ‘OSD’ section of additional hardware. So, this ‘OSD’ telemetry enabler does not work anymore, for sure.
I have a teensy board feeding telemetry into Taranis radio and it is very consistent now - upon restart autopilot only sends ‘heading’ telemetry data, it also sends current flight mode, and that`s it. no battery voltage, current, GPS, no nothing else.

but as soon you conenect 3dr radio to the mission planner or tower app and it communicates with the autopilot - all params get back to life and all keeps working fine after that with proper updates, even if you shut down mission planner and remove radio receiver. it works until next board restart, then it is again, heading data only.

so far no tweaking of any options seem to have any effect on this behavior, and it is very, very annoying.

Been test flying all week 35 flights and 3.5.rc7 seems fine … except one occasion MP stating Bad Gyro … and the usual Telemetry data connection issues to teensy … have to reboot Pixhawk to get it to work each time where as on 3.4 it worked all the time the first go. The only thing i did not test was RTL and Auto Tune. So great work Lads! :sunglasses:

A few questions: why change the decimal point in logs now it has heaps of 0000 and why the current draw reading change then having to run beta MP to correct it ??

Paul, Think you should start a new topic for this, but I think I can offer some advice -
Am I correct in assuming that you are sharing a single Telemetry port between your 3DR radio and Teensy (and that the 3DR radio has both its tx/rx connected where as the Teensy only has its Rx connected - to avoid Tx conflicts)? Lets assume you say yes to this question -
To me it sounds like you don’t have your SRn_ values configured in Ardupilot parameters. When you boot AP, you say that your teensy is only getting heading info updated - this suggests that the SRn_EXTRA2 is configured (as the heading value is a part of the VFR_HUD mavlink message which is streamed inside the EXTRA2 stream), but the other StreamRates are not configured (set to zero). You also get Flight mode, but this comes from the heartbeat message so comes by default. Then when you connect Mission Planner - MP itself has configured stream rates which it sends to Ardupilot upon connecting - so as these SR’s are configured by Mission planner, your teensy data bursts into life. I would suggest re-visiting your SRn_ parameters to make sure these are properly configured. You can find info on the suggested configuration here: https://github.com/athertop/MavLink_FrSkySPort/wiki/1.-Setup#ardupilot-parameter-configuration

Edit: Its also possible that the issue could be due to the lack of heartbeat being sent by the teensy initially (as its Tx is disconnected), then when Mission Planner connects, it sends a heartbeat so the streams start up. Try connecting the Teensy to its own Telem port if you can to test this (connecting both tx/rx). Just to note - the teensy code doesn’t actually send a heartbeat itself (it did once, before my time on the project, but was disabled due to issues) but it does send stream rate configuration commends to Ardupilot, which seem to kick the data streams into life also. I have my teensy sharing Telem2 port with my PlayUAV OSD. My OSD only has its Rx connected, and the Teensy both its Tx/Rx connected, and the teensy telemetry updates the lua page directly as AP3.5-rc7 boots.

Best of luck, Paul (athertop)

Hi all
I have “bad baro health” after upgrade to 3.5-rc7 (3dr pixhawk 1)
I try to flash few time and whenever after flash to 3.5-rc7 messages “bad baro health” appears…
regards

Tomas,
Thanks for the report.
Could you create a new thread and if possible include a .bin file? That will tell us if the baro is indeed unhealthy or not.

Hi mackay
Done
Regards

1 Like

I have done 18 waypoints in a 8 minute mission ( 6m per sec and different alt.) with my quad copter after updating to the FW 3.5.0.rc7 today. No issues including the final RTL. For a different sun angle I repeated the same mission later. Again very good result. I am using a PixRacer.
I will supply a video of that mission to the landowner. Thank,s Randy and Co.

1 Like

Did more flying at the weekend. No telemetry/OSD issues. Everything worked well. Flew PosHold, Stabilize and Acro.

1 Like

Quad equipped with Pixhawk 2.1, Intel Edison, AC 3.5RC7 and AP Sync installed.
ADS-B, APsync Wifi telemetry with Tower connected, all flight modes, LidarLite, MinimOSD, gimbal control,… - everything tested so far works well and smoothly.
Stability in all flight modes is significantly better than the previous Pixhawk1/AC3.4 setup.
Awesome job @rmackay9 and team!

2 Likes

NKF4 and NKF9 Primary Index always zero?
2017-06-08 20-23-20.bin (795.2 KB)
can anyone confirm same problem?

Hi Paul,

I had a mistake with wrong rate specified in some of those parameters.
Link you provided helped and it all works now. My mistake.
Thanks so much!

1 Like