Servers by jDrones

Copter-3.4.5 released

We’ve just pushed a patch release called Copter-3.4.5. This is a very minor change on top of Copter-3.4.4 that includes only one change:

  • Bug fix to Guided mode that could lead to crash after take-off completes if MOT_THST_HOVER too high

This bug would only affect users taking off in Guided mode. Also the vehicle had to be relatively powerful (hovers at well under 25%) and have the MOT_THST_HOVER value set too high (0.5 or higher). MOT_THST_HOVER is “learned” so this would likely only occur on the very first take-off of the vehicle.

We recommend people upgrade at their convenience.

Thanks!

I moved my question to a new topic:
http://discuss.ardupilot.org/t/landing-detection-logic-doesnt-work-for-high-powered-copter-with-kde-motors/14891

Please indulge me with a beginner’s question:

About a month ago I began working with a Navio2 and Mission planner. I downloaded and installed the software obtained from a link at the Emlid site for the Navio2. It resulted in me having ArduCopter-quad 3.4.4, as I could see that displayed on the top line of Mission Planner.

How do I upgrade to this 3.4.5 release, or any new release for that matter? I found what I think may be this 3.4.5 release on the ArduCopter site - the file was named: arducopter-quad.

On the Raspberry Pi the ArduCopter-quad software is located in the directory: /opt/apm/bin/

I placed the new 3.4.5 file in there. I made a copy of the existing file (presumably the 3.4.4 file). Then I adjusted the name of the new file to have upper-case letters where the other existing one had them and rebooted.

The Pi/Navio2 seemed to come up ok on the new release. Is that how to do it? Please advise.

Thanks,

Paul

Hi Paul,

I think that usually Emlid update their OS (or their packages, not sure exactly how it works). We indeed build all releases for Navio2 so it should work by just replacing it like you’ve done. In any case, I think you should ask about this in the Emlid forum as they can give you the best answer.

@staroselskii tagging you here, for your knowledge (and possible better answer).

Ok, at this Emlid Navio2 site:

https://github.com/emlid/navio2-docs/blob/beta-docs/docs/navio-ardupilot/installation-and-running.md#running-ardupilot

There is a command to obtain the latest “stable” arducopter release from the Pi:

pi@navio: ~ $ wget http://firmware.eu.ardupilot.org/Copter/stable/navio2-quad/arducopter-quad

I did this and it resulted in the same 3.4.5 arducopter-quad file as I obtained directly from the ArduPilot site.

If I understand this it appears that the Emlid folks keep up! Thanks,

Paul

1 Like

Hi Randy,
After more than a year i started to get involved again. First i’ve updated the firmware to 3.4.5 followed by a full setup. My Copter is still way over powered, if you remember this is a F550 Hexacopter with 80% of Acro purpose.10% Eagle FPV and the rest Autopilot and other stuff.
I had many problems to setup the throttle Mid on previous Versions because the value was very low 210 or something. As i understand this setting is no more needed ?
I read in the new Docs to set MOT_SPIN_ARM to “the percentage discovered above + 2%) / 100” which is in my case 0.08. MOT_SPIN_MIN should be set adding 0.03 in my case 0.11.
(my Feeling is i should set this values down to 0.06 / 0.08)
Next step will be an full auto tune in case it will be flyable. Should i consider other settings before going for the first fly ?

@Pomaroli, that sounds fine but I would make sure that it flies OK with AC3.4.5 before trying AC3.5-rc1.
Just make sure you have stabilize available as a flight mode.
From AC3.4.5 MOT_THST_HOVER replaces THR_MID and it’s automatically calculated while the vehicle is in a gentle hovering in flight modes including AltHold, Loiter, PosHold. It normally takes about 30 seconds to learn the proper value.

@Randy, seems i’m not getting it flyable for the hovering setup. When i’m pulling only a bit the throttle it Jumps up and i can’t control it. It’s like a On/Off sensation. it seems to me also that the max Rpm is already reached by pulling the throttle to 40-50%. This are KV2050 motors on 4S.
On the older version i was getting it to work by tuning the THR_MID, THR_Min and THR_Spin. Also the PID Tune especially for Yaw was very important.
Is there any pre-settings you could suggest to try ?

Pomaroli,
It’s hard to imagine the problem exactly, a log would be helpful.
MOT_THST_HOVER perhaps?
Don’t forget to do the ESC calibration.

Randy, ESC calibration i’ve done more times, ok i’ll try to set down MOT_THST_HOVER.
Attached the short log but hopefully it’s saying something to you :wink:

2017-03-12 17-33-31.bin (328 KB)

So i’m back getting stuff working, i’ve updated to the neweset Fw and calibrated al things.
I like the new settings like Auto hover in my case it is 0.12. Also the Min Spin and Arm Spin calculation described on the Docs works for me. really nice. Next will be to do a nice autotune.

Hi Paul,

Am using Navio2 and Mission Planner as you do, can i use the cmd: http://firmware.ardupilot.org/Copter/stable/navio2/arducopter to install latest stable FW release to the Navio, now i have APM Copter Ver 3.5 and the latest stable FW release is Ver 3.5.5, help me please

Servers by jDrones