Benewake TF-Mini-I DroneCAN LIDAR not working

I’ve just connected a Benewake TF-Mini-I CAN LIDAR to my Zealot H743. I know this port works because I was running an airspeed sensor on it yesterday. I set
CAN_P2_DRIVER=1 (its connected to CAN2)
RNGFND1_TYPE = 24

The docs say

The RNGFNDx_ADDR ArduPilot parameter must be set above 0 and be equal to the number set on the DroneCAN adapter node.

Does anyone know what RNGFND1_ADDR should be set to for the Benewake TF-Mini-I. I tried setting it to 1 because for the UART option it says the slave ID is 1 in the manual, but it doesn’t seem to say anything about the CAN address required.

There is a copy of the manual here: Dropbox - TFmini-i A01 Manual.pdf - Simplify your life

Also, CAN_P2_BITRATE is defaulting to 1000000, while the docs say that the default baud rate is 250k, I tried changing CAN_P2_BITRATE to 250000 but it didn’t seem to make a difference.

Oh the device seems to be working - when I first power up the FC, I see the red light from the lidar for a few seconds (if I look directly in it - bad idea?), but it stops as soon as the FC comes up.