Bad AHRS all the time

@pilotltd, I had a look at the baro data just now, it does move around by about 3m which is a bit more than I’d expect but they do drift a fair bit. It’s a bit interesting but for now at least I don’t think it’s related to the inability to arm.

I ended up reloading the firmware and trying to re-calibrate again. Cannot get the compasses correct. All that was connected was external gps. Both GPS and Pixhawk are physically aligned and was positioned pointing to magnetic north. Can you have a look at the following please. As yet I’ve had no further response from hex.aero regarding the bad compass and baro problems.

Thanks

I had the same problem.
Check your GPS satellite links. It should be more than 10+ in order to disappear BAD AHRS + make sure GPS cable not close to other signals and power lines.
For compass: Try to calibrate in default or relax mode ( make sure GPS/compass is far from power lines at least 10cm+. Ones calibrated check if it showing right direction and calibrate again instrict mode if you want better direction.( i use strict mode and never had any issues)

Dear Randy Hello

i have this problem too

The GPS green line is frozen but still getting the alarm of UNHEALTHY AHRS

What do you recommend me please?

I’m having the same problem on a new build. I had ARMING_CHECKS = 0 while I was doing all the bench setup and I was continually getting Bad AHRS messages over and over. So after calibrating my accelerometer and compass, I set ARMING_CHECKS = 1 and this message pretty much went away. I’m getting different messages now specifically

PreArm: AHRS: EKF3 Yaw inconsistent (by various amounts).
PreArm: AHRS: EKF3 Core 1 unhealthy

This is turning on and off, so I could probably arm if I just wait for it go go away, and do it quickly before it comes back again.

@timtuxworth please open a new thread.

The “Bad AHRS” message appears when the EKF doesn’t have a good position estimate. It is not a very useful message so I think we will eventually remote this message to be consistent with Copter which doesn’t display this message.

The ARMING_CHECKs parameter value doesn’t affect whether the message will appear or not. I suspect if the vehicle is armed in a mode that requires a position estimate (like Auto, Guided, RTL, Loiter), an EKF failsafe will be triggered soon afterwards and it will switch to Hold mode.

In any case, I think once the calibrations are all done and the vehicle is taken outside it will start working correctly.

1 Like

You said you were going to remove the message back in December 2019 :face_with_raised_eyebrow: