Servers by jDrones

Autotune Mishap with AC3.5 rc 2


(Jeremy Hanks) #21

Heres a link to a long log with disarmed logging enabled.

https://1drv.ms/u/s!Aju__jYAet3UsmnbBbhGfGWg5akM


(Giorgio Rinolfi) #22

It’s 5 days that I cannot understand why autotune mode doesn’t works in AC3.5 rc 2, finally this discussion bring me some hope.
It’s a new build less than 250g with pixracer, 5" …

I try with several batteries but only once autotune starts and after I use the stick to repositioning its stop working.
So here autotune quite never starts, How to make a valuable log for you?

Thanks


(Bob Lasak) #23

Transmitter trims centered?


(Giorgio Rinolfi) #24

I want to confirm that my problem was 3.5 RC2 related, cause yesterday I’ve updated to AC3.5 rc4 and I’ve succefull made autotune 5 times on 5 try out, instead wit RC 2 autotune on the same quadcopter never start. Thanks !!


(Jeremy Hanks) #25

I will try the same.


(tridge) #26

@jimmydaux2 I’ve just found a bug where large numbers of MAVLink messages coming in to the flight board during flight can cause the timing symptoms that happened with your crash (where PM.MaxT was going very large).
I notice that the POWR.Flags field does show that USB was connected. Is there a chance that your companion computer was sending a high rate of MAVLink messages?


(Holger Steinhaus) #27

@tridge What is “large” in that case? Is it enough to connect a GCS during flight, causing an initial full parameter download?

I have had some trouble with very large MaxT values recently, causing major flight instability and also a crash with ArduCopter 3.5-rc4 (see ArduCopter-3.5-rc4: long loops).

Is there anything in the log that allows to identify this situation by lookin into the log?


(Jeremy Hanks) #28

I don’t have a companion computer but the flight controller is an AUAV-X2. I understand there was an issue with this that caused tyre usb flag to be set all the time.


(tridge) #29

ahh, ok, false alarm then


(dany) #30

I can see you are using blheli , how did you set dampedlight and pwm dither mode …


(John R) #31

Hi drvic1,

I know I have DampedLight enabled, but I would have to check on my PWM Dither settings. I don’t remember ever playing with that parameter so I’m sure it’s left as default from when I flashed the latest version of BLHeli, although that was several months ago since the Hexa is flying perfectly and I haven’t wanted to mess with anything!


(dany) #32

since I had two chrash on autotune mode (boath time same way , just aftter autotune started pich tune AC3.5.4 ) , I am considering everything that could couse that faitfull pichover…
when dampedmode is enabled motor are stopped instantly , and whit fact I am running 17"props perhapse that could couse desinc on motros and fall …
now I dont trust anything new … so any advice based on your setup is great
Tnx.


(Fnoop) #33

@drvic1 - if you’re running belhli damped light with low kv motors / large props, you’re pretty much guaranteed to get desyncs. Never used damped light/brake mode with large motors/props.


(dany) #34

tnx fnoop, I did try some flying today whit dampedlight set off , and pwm dither also set to off …
but I still dont belive I will try autotune any day soon …


(Fnoop) #35

@drvic1 I actually use autotune as a test for new motors/esc setup. You really want to know that your motors/escs are reliable and autotune is an excellent way of testing desyncs :slight_smile: If you do several autotunes with maximum aggression and you don’t get a desync that gives me a lot of confidence for normal flying with equipment.


(dany) #36

ok that great thing to know , but how do you insure yourself from breaking some K$ machine in peaces when desinc acure…
in other words is there any other way to test desinc before flying and doing autotune…


(Fnoop) #37

You don’t until it nosedives! Choose good ESCs for your motors - hobbywing do ESCs specially for larger motors/props that apparently are very good at not desyncing. Don’t use damped light/active braking modes. Test, test, test without any expensive equipment on board. Research what ESCs others use for similar motors/props.


(Mike Boland) #38

The standard test method is to assign your throttle to a switch, which enables you to go from no throttle to max very quickly.

Either lash down the copter or put the props on upside down, or both.
Safety first, but you need the load of your props on the motors.
It will quickly show you any desynchronising issues.