Servers by jDrones

About Lidar Lite v3 support


(Arif Gezalov) #42

Thank you! Will experiment with that.


(wkf94025) #43

My LIDAR-Lite arrived today. I bought it for a non-aerial application, but on the side I will be plugging it in to Arduplane latest on a Radian XL. Fingers crossed…

Kelly


(Michael Brooks) #44

Has this been documented yet? I’m also trying to use analog sonar for collision avoidance but can’t find any details about all the parameters to set?
Thanks


(Zachery Wheat) #45

Do you have a link for the wiki for wiring the v3? Im awaiting my lidar lite v3 in the mail and am trying to get prepped to set it up.


(Zachery Wheat) #46

@rmackay9 scratch that question. Im just an idiot and didnt scroll down far enough haha But according to the Lambdrive link above, we can power the Lidar Lite via an extra aux port on the pixhawk? Instead of a separate BEC? Also, Ive been seeing that people either set the RNGFND_TYPE to 3 or 15, with 15 apparently skipping version detection and acting like a v2. Why would you want it set to 15 and it acting like a v2? Isnt that the point of getting the updated version is so it runs better? Or am I missing some information?

Thanks


(ppoirier) #47

@zwheat
Garmin has no HDW_VERSION nor SW_VERSION. mapped into registers, this is why we have to force v2 and skipping the test.
Other difference between Garmin Lidar lite v3 and lidarlite v2 is in the method to read the registers, v3 need a split transfer method take a look here:
https://github.com/ArduPilot/ardupilot/blob/master/libraries/AP_RangeFinder/AP_RangeFinder_PulsedLightLRF.cpp#L154


(Zachery Wheat) #48

Hi guys,

Returning to this chat after several months off, rebuilding the drone and not having weather to fly it. My boss and I put a new Lidar Lite v3 on a smaller quad for some testing, and the Lidar is working extremely well for altitude hold while in one position or moving through a waypoint file.

The problem we are having, is after we arm it and take off, when we switch to AUTO, the quad races for the sky, and wont stop unless we flip it back to loiter, and decrease the throttle. Then if we go back to AUTO, it flies the path just like it is supposed to.

Any idea whats going on? We double checked out setting in the waypoint file and it should only go about 4 meters up and head to the first waypoint when we go into AUTO, but it isnt the first time around.


(Zachery Wheat) #49

If this isnt a Lidar Lite issue and you think it is a Pixhawk issue, I can switch where I am putting the questions


(ppoirier) #50

Hello
Can you attach a log file so we can look at it?
Di you updated the firmware release on PixHawk ?
Have you tried in guided mode ?