Yuri's 4.1.0-beta Update (GPS yaw - now 4.2.0-dev)

I also use TELEM1, though I’ve moved the telemetry around a bit at times, and I actually have RC telemetry connected to TELEM2 as well. What telemetry hardware are you using?

I don’t know if you can get rid of the HUD displayed battery voltage, but you can definitely disable any battery failsafes.

If you don’t have RTK Float or Fixed on GPS1 (the moving base), your NTRIP corrections are not making it through. The fact that you have RTK fixed on GPS2 (rover) is good - that means that GPS yaw is possible. But that status is coming from the fact that GPS1 is providing RTCM3 to GPS2.

Kenny it becomes more clear now.But i now have some more nobb questions.

If i set the F9P s first UART to output RTCM at 230400 and to recieve RTCM at 38400 at F9P s second UART and possibly send possition to pixhawk from same port at same speed. Would that be ok ? Or both GPS s have to send at 230400 to Fmu ?

And what would happen if i send combined data UBX+ RTCM (and NMEA) to c94 but set it to get only RTCM in.Do you think c94 would be able to “chew” that and get usefull RTCM out of that ?

Thanks ,Kenny Hope to be up and mowing soon.,
Have a Blessed Day,Rustey

OK ,Yuri again thanks, can that be the problem with failsafe that the two gps 1&2 do not agree?
Regards Rustey

I’m using aerosky 900Hz

You won’t get a failsafe just because RTK corrections aren’t happening on GPS1. There should be messages telling you what failsafe is triggering.

In theory, since you will be configuring the GPSes yourself (not depending on ArduRover), you can set the baud rate between the Moving Base GPS and the Rover GPS to anything you wish. I had mine previously at 115,200 and it worked fine, but I was using exclusively F9Ps with 2 UARTS.

BUT, I do not think it matters that you can theoretically set the baud between the GPSes to what you wish because of the single UART issue posed by the C94-M8P:

The baud rate for any GPS UART connected to the Pixhawk in the GPS for Yaw configuration, needs to be 230400 as that is the baudrate that ArduRover will set up the Pixhawk GPS and GPS2 ports. When you set GPS_TYPE to 17 and GPS_TYPE2 to 18 (for GPS for Yaw), ArduRover ignores the SERIALx_BAUD parameters for the GPS and GPS2 ports and sets them to 230400.

For proper GPS for Yaw, the Moving Base GPS and the Rover GPS should be connected to the Pixhawk. Since you plan for one of those to be a C94-M8P, which only has one UART, that UART’s baudrate will have to be 230400. That, then sets the baudrate coming IN to that UART at 230400 also, which sets the baud rate of the GPS feeding it to 230400. I might be going around in circles, but it is clear to me, that you will have to have the baud rate at 230400 for all GPS UARTs.

Thanks for helping me in this.I have assumed that i dont need to set type 17 and 18 if i connect both gpsses directly between themselfs as i read somewhere here.I must have missunderstood or it has changed. So 230400 is the key indeed.Thanks

I think you need to set the GPS types to 17 and 18 so that ArduRover will know that you have a GPS for Yaw setup and will use the heading information from the GPS to determine the vehicle heading.

1 Like

If you look at the way ArduSimple suggests using their daughter board configuration, it appears possible to just have a single connected rover GPS tagged as type 18 and still get yaw, so long as the moving base is providing RTCM3 to the rover. That is not in accordance with the developers’ suggested configuration, and I can’t recommend it as a viable long-term solution.

2 Likes

That detail might just allow me to try my nonstandard constelation with c94 :grinning:.

I have tried a few combinations and the closest i get is using fixed base C94 and rover that obtains RTK fix. I feed RTCM from C94 rover to F9P second UART and it reaches float only, but with gps heading precision within one degree in u-center. On pixhawk i configure f9p as type 18 and C94 as 1 (auto) and both show up respectively. While RELPOSNED in u center shows correct heading and distance between antenas, i dont get usable heading in pixhawk. I get yaw 65535. The rates are set to 4hz which is kind of max for C94 using two constelations. I have ordered another f9 (to avoid frustration:) but i think this could work as well.

Anton, It sounds like you have done some good experimentation. It is hard to know if you are just missing some small setting or something or if there is a reason this won’t work because of the expectations of Ardurover. If I had time, I would be interested in trying this also, but it would take a good bit of wiring and modifying what I have working. It would be nice to make use of the old C94 modules I have. But, I may use the C94s on some other vehicles that do not need the precision of a mower.

I think you made the right (but expensive) choice to get another F9P.

Thanks Kenny i knew you would understand. After all i try to follow your discoveries with a year or two delay :slight_smile:

1 Like

I have Rover 4.1 and are trying to set up GPS Yaw using two Zed F9p boards. I followed the tutorial on the Ardupilot wiki as well as everyone’s recommendations on here however even with setting the GPS offsets, the direction of the vehicle is about 130 degrees off. I am connecting the two UART2 between the two GPS boards. Any idea on how to fix this?Yaw_params.param (14.7 KB)

What are the physical locations of your antennas with respect to the autopilot?

A picture might be helpful.

GPS 1 Antenna: 14 cm forward, 16 cm above, 2 cm to the left
GPS 2 Antenna: 56 cm behind, 16 cm above, 2 cm to the left

GPS 1 is in the front of the vehicle while GPS 2 is in the back of the vehicle. Also to note the autopilot is rotated 90 degrees to the right.

I’ve also reversed the offsets but it still points in the same direction

I see no smoking guns in the parameter file. Are you actually getting valid GPS yaw? If you look in the MAVLink Inspector, does the value for GPS2_RAW.yaw show a value between 0 and 36000? What is the GPS fix status for GPS2 (RTK fixed)?

The GPS2_RAW.yaw has a value of 65535 and the status for GPS 2 is rtk float

65535 is an error value. The fact that you have an RTK solution on GPS2 is a good thing - it means that your UART2 connections are correct. However, the solution is not good enough to provide yaw. Give it some more time to initialize (disarmed and stationary) and/or make sure there is a clear/unobstructed view of the sky.

1 Like

Thanks! I will move it to a more clear location and wait for a longer time to see if it gets a better signal.