Servers by jDrones

Yuneec ST16 Transmitter Support?

Unfortunately I don’t have a TX to bind with it.
could you verify if your TX can bind with sr24 using above approach?

WOW! Good work!

I can test that, but I am a novice with regards to serial connections. Can you give me some guidance on how you connected it? Maybe a picture or diagram of the wiring? Is it as simple at TX<>RX, RX<>TX, Vcc and GND? only thing is i think the sr24 is 3.3v - isnt USB 5v?

Any recommendations on serial port tool? Ive used PuTTy at work a few times - will that do the trick?

yes, actually 3 wires are enough:

  • pin 1- Black, GND;
  • Pin 2 - White, 3.3V;
  • Pin 3 - Gray, connect to TX of PC
  • Pin 4 - Yellow, no need connect. You can connect it to RX of PC, but in my testing i didn’t get any response from it

regarding the tool, I’m using on Mac.
I believe putty should work as well

Seems simple enough. Ill try it this weekend!

@ysome - i cant seem to get my SR24 to react to

I am using RealTerm set for 115200, n, 8, 1. But there are also a ton of other settings that i dont have enough knowledge to understand.

I accidentally put 5v on the RX/gray wire…just got the wrong pin. TX light on my serial/usb converter flickers and the terminal sent it, but no reaction on SR24. Did I kill it with 5v on gray?

I tried an OSEPP ftdi and another no-name silabs converter

only these 115200, n, 8, 1 is important for serial connection, you can just ignore other settings.
in my testing it is quite strait forward.

I find somebody in China has already hacked the entire yuneec protocol, he has developed a tiny board which can:

  • switch sr24 to binding mode without yuneec FC
  • convert sr24 signal to standard PPM or SBUS signal
  • 5 ch PPM signals output, for servo and/or esc
  • 2 way communication between FC and RC
  • control yuneec gimbal

it is interesting, but only a few proto board available, not for sell yet.

Do I need to convert the hex to ascii or anything?

no need, just send those 11 byte data as hex.
so your serial tool must support sending hex data.

you shoul be able to see TX count 11 at somewhere on your tool

I have not been successful with the hex command, but I am not fully confident I am getting the command sent. is there anything special about hex format? as long as the numbers and letters 55 55 08 04 00 00 42 49 4E 44 B0 get sent in that format, it should be all good, right?

maybe i am just second guessing myself…

The TX light of my serial converter flickers but its a really weak flicker

the tool i’m using is CoolTerm for mac
serial port settings:

then, send it out as Hex:

that’s all
I’m already able to bind sr24 with st10c transmitter using this approach.

if you are still having problem, either your sr24 is faulty or wrong wiring

another possibility is that your sr24 module is for tx but not for rx.

you know yuneec use the same sr24 module in both the transmitter and drone
it is difficult to judge if one sr24 is for rx or tx from its appearance, since only the firmware inside is different.

It worked! I tried X-CTU’s serial console which is much simpler. I clearly had no business with the advanced features of Realterm.

I got the fast blinking light, then put the ST16 into bind mode and it turned solid.

…Now…I cant seem to get this pixhawk to recognize the receiver. Is there anything required to activate the DSM port?

sorry, I don’t have any experience with pixhawk.
what I’m trying now is to make an adaptor board using arduino, which can convert sr24 to standard pwm. then I can use it in my rc toys

@tridge - is there anything required to run the st24 RX protocol? FWIR, it should auto-recognize the RX protocol, correct?

Anyone? I need some help here…

Does the st24 protocol even function?

As far as I can tell the protocol should just work. I’ll try binding another receiver with that hex trick next weekend.

Binding worked perfectly using an Arduino to send the hex, but got the same manual control lost error in QGC. It seems that it decodes the first packet correctly and displays it, but fails on the rest. This looks like an error in the Pixhawk firmware, probably in the sr24 decoder. I’m going to try and copy the decoder code from GitHub and run it on an Arduino to debug it, if I can get it to work or if I find a bug I’ll open an issue on GitHub. Also, since Arducopter and Pixhawk are very similar it may very well be the same bug in both.

Binding has been working great. Ive successfully bound it many times now.

I am not sure where to see the “RCInput: …” message, but it is in the AP_HAL_ChibiOS/RCInput.cpp:

I tried watching the ‘messages’ tab in Mission planner, but it never showed up there. Mission planner just shows “No RC Receiver” in the HUD at all times and I get no response at the RC calibration page. I tried calibrating, but still nothing.

I can see the sticks moving around on the ST16 HW monitor page, but I am not sure if this is at the actual TX output point or at some point before that. At this time I can only assume that the stick movements are getting to the SR24.

I will try mavproxy and see If the “RCInput: decoding %s” shows itself.

It looks like other users are having trouble with Spektrum RX as well:

Unfortunately, it looks like the solution is commonly to bind in 11ms mode instead of 22ms mode. I dont think we have that option with the Yuneec SR24.

I noticed this comment:

In addition, beginning with ArduPilot firmware releases 4.0 and later, any UART RX input will auto-detect the RC receiver, if attached.

…Does that mean that we can connect the SR24 to ANY UART port? (Assuming the ST24.cpp protocol is functional, obviously)

Servers by jDrones