Yaw rotation on Takeoff and first setup log

Based on that chart you should have plenty of thrust. The current looks about right. Log shows ~50a total at hover. I suppose move ahead with your plan and see how it shapes up!

Yeah I thought so too. But looking at the actual data it seems the T-motor chart may not be correct at all. Good to know the currents are correct. But indeed lets continue and see how this ends up.
First vibrations to fix.

You don’t have the [down in] Flames or the Alpha/Omega ESC’s do you? :slightly_smiling_face:

Alpha esc. Its a T-motor set > mount/motor/esc.
https://uav-en.tmotor.com/html/UAV/Multirotor/PropulsionSystem/DroneArmSet/

Did some testing today. Only in stabilized to check vibration results

Some softer dampers on the kore board.
Checked all internal wires not pulling or loose.
Removed landing gear/weight and damper. Copter was mounted on a square alu tube frame. supporting only 4 boom arms (total weight 21kg)
Supports under the battery tray

After a second look at this chart. Seems that at 56% its 4271gr x 6 = 25.6kg. So more then half of the 10kg lift is in that last 44%

Z-vibe levels are still too high. The thrust/weight looks pretty good at that weight. If that’s the best you can do with vibration then configure the Dynamic notch filter.

Thanks Dave for checking,
It could be that the boom arm’s are to thick / stiff (stiffer then the center plate). Its 27/30mm so wall is 1.5mm. Its possible to replace them with 28/30
Lets test notch and put the landing gear back.

I’m rebuilding the hexa to mount the gps higher and further away from the batteries.
Also changing the boom tubes to 28/30cm so that they are less stiff. Lets hope this fixes the Z-vibration transfer to the FC.

Regarding Rc control and Osd. We are using Crossfire Nano TX/RX with Frsky Taranis X9D rc control via Sbus atm and the Holybro micro osd v2.
We came from PX4 and all Mavlink telemetry to Taranis and Holybro where working fine. But when we moved to Arducopter 4.07 None off the Mavlink info was received on either the Taranis or Holybro. Both are set to 57000 Baudrate and Mavlink version 1 (Also tested 2).
The Nano RX is connected via port 3&4 (set to mav tx/rx in Taranis) to Telem1 and Holybro to Telem2.
We just installed Copter 4.10 and the Holybro worked directly after the update but stopped working after we rebooted the FC. After that it never worked again (Waiting for heartbeat). We did change Osd_type to 1 > Max7456. Serial2 is set to Mavlink version 1 an 57000 Baudrate.

We also tested CRSF on the new TBS TX/RX update and we get Full RC control and Mavlink Telemetry. But the Holybro osd is still not working.

What is currently the safest way to control our copter > Sbus or RC/Telemetry over CRSF?