Yaw rotation on Takeoff and first setup log

Hi All,

We started with px4 on our new 25kg Hexa. It was flying well in Altitude and Manual but not in position hold. We could not figure out why this could not be fixed with tuning. So moved to Arducopter to check if this could make a difference.
We did the initial setup according to the Wiki and also used the initial parameter xlsx from Shawn (xfacta) Thanks !!
It’s flying ok with stock PID’s in stabilised (did not test Alt hold or loiter yet). But on takeoff the drone rotates to the right. We tested with only the mag in the here 2 gps and got the same issue. Does the software correct for the offset when calibrating or do i have to set this in Mission Planner. Is this issue offset related or is this from bad yaw tuning?
I’m also seeing more vibrations on the Z axis than XY in the log file. Do i fix this with PID tuning or is this filter / frame build related?
We are using Cube Blue, ProfiCnc Kore carrier board. Here2 gps. Tmotor 705-s 125kv. Tmotor prop Fa26x8.5. Alpha 80Ah Esc.

Let me know if i can supply more info and thanks for any help on this.

Logs and param files Connecting...

Looks like power interference. The external mag (green) is best as expected but there is still influence. Better isolation perhaps.

The Z-vibes will have to be addressed. They are too high with clipping events. This will be a mechanical issue.

Where can I select all those magnetometer parameter in log analysis page.I was searched all the parameters on right hand side of the log graph analysis page. What key word for the parameters to extract?

The pulldown menu.

1 Like

@dkemxr thank you so much.

Hi Dave. Thnx for checking.

I assume that the external is on the i2C poort. We tested this by deselecting the other 2 in mission planner. But i’m not sure if we did this correct.
We did have the same yaw issue with px4 until we select a 270 degree rotation on external mag. But with px4 it rotated to the left and not to the right so i’m not sure its the same issue.

Will post a pic of the frame. I’m not sure if there can be made any improvements. The Cube / Kore board is mounted with some hard vibrations dampers. Should this be hard mounted?

Yes. You can determine that by the HW ID and then see what Bus it’s on. It’s the 1st thing I looked at to make sure you had the external one as Priority 1. And you do with others disabled. So far so good there.

The question about hard mounting is kind of loaded. Many will say, including the Cube manufacturer, to hard mount it but there is plenty of anecdotal evidence on the forum here that with some craft more isolation is needed. But everyone would agree that adressing the source of the Vibration is a primary goal.

1 Like

It is correct that the GPS/Mag is close to the battery tray. This is because we want to use the option to mount the movi on top of the frame. We did not look into this yaw error anymore with px4 as the issue was gone when set to the 270 offset. Do you think the noise is to high?

I will check if mounting with softer dampers fix the vibration on the Z axis.

here’s a picture of the frame

Yes, it’s certainly from close proximity to the battery. You could try performing Compass Motor Compensation ( CompassMot). Care must be taken when running it on a big craft!

1 Like

Thnx. I will look into this setting.
Edit; It seems this could work. But I’m not sure this is an route i like to go. Think moving the gps/mag is the only solution.

We did some testing today to see how much the compass is affected. Weather was very calm unlike our fist test.
We tested with battery tray below frame and also with all compasses disabled. In the logs the Mag field vs Throttle looks the same. With Battery tray fitted on top again the yaw rotation on take off did not occur. Weird. So we think the yaw was related to wind and low PID.
Second test was autotune on all axes independently. Yaw first (@ 0.1), roll second (@0.05) and pitch (@0.05) last. Roll pid is much higher. Don’t know why yet. Still no notch filters set. Battery tray has some flex. Which we will fix.
Have been reading that after autotune the ATC_ACCEL_P/R/Y_MAX would get at higher setting. Do we set these lower according to Shawn Initial parameter excel > 29800 for 26 inch props?
Also tested Alt hold and Loiter. Both worked well.

We did not fix the z axis vibration yet. This is next on our list. Same for notch filters

Thanks for the help. Got us going

Last log and Param file added

That link doesn’t work.

Log link edited. Connecting...

Did one longer test flight today. No filters yet. Only parameter test on RTL.

I don’t see the link working.

Your right. dont know why. i will go different route.

Edit; org link should work again. But also uploaded on filemail > Download files - Filemail
But this link is only active for 1 week

Coming weekend we will change the dampers for softer ones to check the z-axis.

A few observations:
Thrust to weight is a bit low. Average Commanded motor output is ~1650µs.
Vibration as mentioned is very high. Pointless to advance w/o addressing this.
MOT_SPIN_ARM is higher than MOT_SPIN_MIN.
After fixing the vibration issue and configuring the Dynamic Notch filter you will want to run Auto Tune with the default aggression (.1). Low values like you have (.05) can result is some very low PID’s and instability.

Hi Dave, Thanks for checking. Its a big help

Got it. We will address the vibration first.
Ok. clear. i think i made an error regarding the mot_spin_min/arm.
Can you elaborate on the Thrust to weight? I’m unsure what this means.

Sure. Ideally you want to Hover ~50% throttle or 1500µs commanded output. In this graph I included GPS speed to be sure it’s in a hover condition at this time. Average commanded output is ~1650µs.

So slightly overweight/underpowered. This might be OK but under high demand the commanded motor outputs could max out and then you will loose stability. You will know when this happens if you see “Thrust Loss” errors.

Ah. That make sense. Nice explanation.
When i looked at hover throttle when learn is enabled i thought it was between 50 (param file today) and 53% (param file from okt 10) But i might understood the function wrong.
Total weight is 25kg so if the motor prop combo don’t have the enough power it seems that T-motor are not very accurate in there specs.

Edit. just checked the logs from the Px4 software. And they are at the same output > 1650