X packets received but no parameter packets

We’re trying to connect mission planner and APM via the 3DR radio’s. It worked with an older version, but since we’ve updated a couple of versions it has never worked again and thus we can’t continue.

Is there a known fix for this, if not, is there a way we can get the 2.38 firmware (that was the version that last worked for us).

Hi Myth1c,
I am presently running the latest ArduRover code v2.41 that can be automatically downloaded with the MP and my 3DR telemetry communicates okay between the MP and the APM. Have you checked all of your transceiver parameters to make sure that both radios are the same?

Hmm… Both of our radio’s have the same parameters.
We’ve ordered a new set of radio’s to rule out hardware failure. They will arrive tomorrow.

See below for a screenshot of the configuration:

We got the new radio’s today and tested them elsewhere first. They functioned properly in another project!
In our project however, still the same issue :frowning:

I am having the same issue, did you ever figure your problem out?

Using the mission planner or apm planner you can try to load the latest firmware SiK 1.9 and reset to defaults both boards, later you can modify the NetID in both radios if you don’t want to stay in 25 which is the default value.

I have tried Version 1.9 and 1.7. My Radios will talk to each other fine. I have the GREEN LED light and when I try to connect to mission planner it fails only when downloading the params or waypoints. I can get realtime data if I connect using Control T . I Also get the same real time data by hitting the connect button but it drop after the params don’t load. I looks like my transmit is not working or its waiting on a CTS or RTS signal though these are not selected.


any solutions found?
Thank you for your help