Wrong speed in AUTO Waypoint flight - copter

Hi
I need to force my copter to flight with 20 km/h speed during way-point mission. I planned mission in Mission Planner, created region with poly lines and set “Survey (Grid). I also checked “Use speed for this mission” with 20km/h. I even can see in commands “DO_CHANGE_SPEED” 5.55” but when I take off my copter always fly with speed around 16 km/h.

As I read in wiki I set WPNAV_SPEED to 5,8 m/s as fastest speed of copter in waypoint flight. Copter can fly 40 km/h without problems… in RTL it fly 28 km/h.

That’s big hexacopter 12 kg weight with 18" propellers with Cube Orange

What I am doing wrong ?
I am attaching log file from flight with wrong speed… and planned flight file

Hi
can anyone help me and explain how the

“DO_CHANGE_SPEED”
function in planning mission in Mission Planner works?

and how WPNAV_SPEED is connected with it ?

Why I can’t set the speed of the copter in waypoint flight ?

You should use ArduCopter 4.2.1 and calibrate the PIDs and other flight parameters to achieve that speed. Some people in this forum have achieved 80Km/h. Just search this forum for it.

Hello @norim

In general lines,

This one is a mission command executed by your drone to change the navigation speed between waypoints. At any point of your flight plan you can include this command and fly at various speeds.

This one is the standard speed your drone will use to fly by waypoints, if no DO_CHANGE_SPEED mission command modifies it.

@amilcarlucas I can achieve faster speed in Loiter and RTL. I think my PIDs are ok. I can’t set speed for waypoint flight.

@BrunoBagarini If I “DO_Change_Speed” it will work only to next waypoint or during whole flight after execute this command ?

During whole flight or upon the execution of a new DO_CHANGE_SPEED command.

1 Like

Ok so why DO_CHANGE_SPEED doesn’t work in my copter ? I set 20 km/h copter fly 15-16km/h…

Does it obtain the speed if you setup a simple 2 point mission with some distance between the points so it has a opportunity to accelerate and sustain a stable speed?

Increase these:
WPNAV_ACCEL
WPNAV_JERK
And even if it’s not required to make 20km/h increase this ANGLE_MAX

1 Like

Hi I did same more tests. I think that’s not a problem with configuration of my hexa because when I created simple waypiont mission in Mission Planner (just 2 waypionts and DO_change_speed" command copter did everything correctly. I also checked survey mission in qground controll I can fly in such mission with even 32 km/h no problem…

So that’s a problem with “survey” option in Mission Planner or with Arducopter firmware…or parameters which I don’t know. Mission Planner is creating many waypionts every 10 meters. Maybe copter is slowing down before it reach every waypiont and can’t reach desired speed like 29km/h. Please check this mission form Mission Planner and this from qgoundcontroll. QGC is using much less waypoints…and for taking photos using other command…

The option “survey-grid” in Mission Planner is generally the best. It gives much more possibilities and information than in other Ground Stations. That will be hard to use other software maybe this bug will be repaired ?
@Michael_Oborne could you help ?

The bug has been repaired already in ArduCopter 4.3
But you still need to follow the instructions from Dave to get it to wor reliably.

Could you provide any more info ? Any link ?

Check the recent GitHub commits to master branch.

1 Like

As I understand that’s the bug ?

My pull request had no effect on any possible bug. It simply exposes the change speed logic to scripting.

The changes I talked about are not on a pull request they are merged in the master branch.