Servers by jDrones

Where do I position the throttle for auto takeoff?

(wsalopek) #1

I have looked and looked (and looked and looked) for this answer…but can’t find it…

Where do I place the throttle for auto takeoff? Indeed, what is the procedure? The docs don’t address the actual procedure…like step one, do THIS, step two, do THAT.

I loaded a mission starting with auto takeoff (which the docs call NAV-TAKEOFF, but which doesn’t exist, as far as I can tell in Mission Planner).

But when I switch to AUTO, and raise the throttle, and even though I have set the other parameters correctly (so the prop doesn’t start before certain conditions exist), THE PROP STARTS.

What’s going on?

Thanks…

(wsalopek) #2

Did some more looking…I saw a video where the pilot armed the plane, switched to AUTO, and raised the throttle…the throttle did not start (mine DOES start)…he gave the plane a toss, and the motor started as designed.

When I switch to AUTO (verified by telemetry and the elevons moving slightly up) and raise the throttle my motor starts immediately…in other words, “suppress throttle” is not working.

Also…

Saw a few videos where folks armed the plane, switched to AUTO, and did NOT raise the throttle (so now I’m guessing that NOT raising the throttle is the correct procedure)…pilot gave the plane a toss, and the motor started as designed.

When I give the plane a toss, the motor does NOT start.

However, I am trying to toss an FX-61…telemetry seems to show my acceleration is about 2m/s (though I’m not sure if it’s the X,Y, or Z axis)…and my accel parameter is set, as the docs suggest, to 4m/s…so that’s the next thing I’ll try I guess, drop the accel to 2m/s…it bothers me though that the docs suggest 4m/s as a minimum.

(Kikislater) #3

Please give your params
TKOFF_THR_MINSPD: Takeoff throttle min speed
TKOFF_THR_MINACC: Takeoff throttle min acceleration
TKOFF_THR_DELAY: Takeoff throttle delay

http://ardupilot.org/plane/docs/parameters.html

How I set “shake and go” auto mode on fx61 :
TKOFF_THR_MINSPD = 0
TKOFF_THR_MINACC = 3
TKOFF_THR_DELAY = 1
Note it will work only one time if you set MIS_RESTART to 0 and will work all the time if you set to 1. You have to reboot your FC if MIS_RESTART is set to 0 to enable it again. You could assign a channel with RST_MISSION_CH to reset mission to first waypoint.

RTL_AUTOLAND will also interest you if you look for auto mode like auto take off and landing

If you are in auto mode, THR value on your RC will not have effect. Only if you have throttle nudge set to 1. Otherwise it will take TRIM_ARSPD_CM if you have airspeed sensor or TRIM_THROTTLE if you don’t have in auto “cruise” or "mission flight mode. Motor acceleration from start to proper value is controlled with THR_SLEWRATE. For Takeoff throttle motor value will go up to THR_MAX or TKOFF_THR_MAX if you have set it.

Good Luck !

(wsalopek) #4

Kiki…

Parameters:

My parameters (taken straight from the arduplane docs):

TKOFF_THR_MINSPD: 4
TKOFF_THR_MINACC: 15
TKOFF_THR_DELAY: 2

Shake and go:

Very interesting. :slight_smile: I’ll look into that…I see your parameters are all lower than mine. Is there a thread somewhere that explains/shows it in more detail? It looks like you:

  1. ARM, throttle remains at zero.
  2. Select AUTO
  3. Pick up the FX-61 and shake in a forward/back (X+/X-) motion.
  4. You have 1 second to throw the aircraft before the motor starts.

Question…do you throw the FX-61 with the motor turning? Or do you try to throw it BEFORE the motor starts? If so, are you shaking overhead?

Restart mission:

I have a channel assigned to restart mission…each time I would throw and the motor would not start, I would hit my switch to restart the mission (or a couple times I rebooted).

Throttle nudge…

THROTTLE_NUDGE…yeah…I had it on 1…so that’s why the motor was starting after I engaged auto takeoff? Hmmm…seems like nudge should be disabled for the time before motor start in auto takeoff…but…great…I’m glad to know why my motor was starting…so I now have that set to ZERO.

So now my only question is why is my motor NOT starting when the aircraft is armed, AUTO is selected and the throttle is set at ZERO. And I’m thinking the only remaining possibility is that I’m not throwing it hard enough to reach TKOFF_THR_MINACC = 4.

(Roger Ronald) #5

There is a tricky thing in the auto take off sequence.

If I remember correctly, you must avoid passing thru other auto modes prior to setting auto take off if you want it to work.

I have my modes set up on a 6 position rotating switch. Like this:
Manual
FBW-A
Circle
Loiter
RTL
Auto

But…I also have a safety switch on my transmitter that locks out the throttle and disables any automatic modes (forcing FBW-A if an auto mode is selected by the rotary switch). The reason for this is very important. In auto modes, even if I have the throttle “off”, the pixhawk can spin the motors. So, a good safety switch setup must disable throttle AND must also disable auto modes! Since my safety switch has 3 positions, I made it:
POS1- Throttle off, manual modes selectable, “Motors off” voiced"
POS2- Throttle enabled, only manual modes enabled, “Manual throttle control enabled” voiced
POS3- Throttle enabled, all modes enabled, “Execute Mission” voiced

If I enable all modes and the throttle and then rotate the mode switch from manual around to Loiter, then RTL, and then Auto, Auto Take Off will fail to trigger on acceleration and I look foolish shaking my plane with nothing happening.

The correct sequence is to leave my safety switch off or at the center position that only enables manual mode throttle. If I then rotate to the auto mode setting and subsequently enable the mode, auto take off will work every time.

4m/s is not a huge push or shake. On my big twin plane, I do a shake and have my plane ramp the motors to full over a 4 second period while I hold it back. At the end, it’s trying to carry me away and it’s time to throw (or just let go).

On smaller pusher planes I just toss the plane and the motor starts after the push has happened and the plane is 5 or 10 feet away.

All my planes have “throttle nudge” enabled. But the throttle is always set to zero during takeoff (since a spinning motor prior to the take off is very hazardous).

There was an exception for using throttle nudge during auto take off. When I did catapult launches, I would advance the throttle a small amount prior to firing the catapult and auto take off. Not enough to move the plane, but enough to have the prop spinning. As soon as I fired the catapult, I would fully advance the throttle. These actions slightly reduced the lag of getting the motor to full speed.

RR

(Roger Ronald) #6

Oh…one more thing. Do your takeoff attempt and look at the logs. If you don’t get enough accel, you can see what it the x axes acceleration was and and then lower the value that you must achieve. If you do get enough accel, it will log a message about starting the auto takeoff.

If it’s aggravating you enough, take the prop off and do the testing inside until you get things right.

(Kikislater) #7

Like this :

Arm in FBWA, switch to auto and throw when throttle reach high noise