When I connect Mission planner it only updates one paramater

So after the latest time that had to reformat my SD card I tried a high speed card as suggested. I reloaded the 3.1 firmware, and then tried the beta firmware. Both times when i try to connect mission planner the Connecting mavlink screen comes on, then it will get the parameters like normal, but then one of two things will happen. Either it will get only ~1-2 parameters, or it will get all the parameters but after around 130 it starts just numbering them instead of displaying the names. When I try to fly it now it is way out of control. Something is wrong…

I have tried holding down the button on the side on power up, ad formatting the SD card. Nothing changes this behaviour. When I tried to fly it it was terrible and then it lost ESC calibration again. This setup was all working perfectly. I even tried it again with the 2gb card it came with and it still only just gets the two parameters when it tries to connect. Makes me think something is wrong,

Hobbywing 40A ESC’s

Stick with the released firmware.

Watch this

Once you have done that and you are getting the correct startup tones you should be good to go.

If it is not downloading the parameters properly, then you have some kind of a serial port problem. Can you try a different cable or a different USB port? Do you have a powered USB port you could try? Can you connect the USB cable and then the battery and then attempt to connect from Mission Planner to the vehicle.
Also are you using MP In windows or a virtual machine?

I am using windows, I will for sure try different USB ports in the morning.

I am pretty sure I was following the startup correctly, but I broke the connector on my speaker and I keep forgetting to order a new one.