Weird Yaw Issue


I have been flying on Stabilize and Alt Hold mode to fine tune the helicopter and all was working well. I have made probably 10 flights without any issue on Yaw. Today I start to see yaw not holding up and slipping to either way and I have to make RC input to fix the heading.

Literally I have made no change on settings nor on the mechanical side so I am not sure what could be the issue.

I am attaching the flight log of the flight that has no Yaw issue and the one with the yaw issue.

No yaw issue flight log:

The yaw issue flight log:

trex700gasser.param (14.8 KB)

Any help is appreciated.


Could be a sign that your tail servo or the tail mechanics are starting to go bad.
I’ve had potentiometers in servos go bad on me before such that they don’t center as well as new.


Yes that could be a reason. My current tail servo is align ds620 and I was planning to upgrade it to DS655, I guess now I have a valid reason. I will see if that is the case. Thanks…

That servo should be more than up to the task. Maybe check for play in the tail linkages and mechanics (bearings/etc.)

I would set the RC4 dead zone a bit higher

I don’t see any stray RC4 input signals from the RC, but I usually run 30 on the dead zone for yaw or it will cause problems in Auto flight sometimes.

The servo looks fine to me. It’s responding to the servo outputs on SERVO4. However, running throttle mode 2 with a setpoint with a piston engine is NOT a good idea. If what ever you are using for a governor fails you have no backup via throttle curve. It would lock at 43% throttle and the likelyhood of a piston helicopter making it home with the throttle locked at one value is very low. And it would severely over-speed on landing when the collective pitch load comes off.

Due to the way I see the tail jerking in the log it looks to me like either a governor problem, or engine tune causing the engine to four-stroke or misfire. RC format engines have huge rotating mass in the crank and flywheel and it really looks to me like the yaw is fighting this.

Did the density altitude change since the last time you flew? Warmer or more humid weather? So the engine is running rich and mis-firing? For RC format Zenoah engines with a Walbro 990 the outside mixture screw (closest to the air filter) is the high-speed jet. It normally requires about 1/8 turn leaner at high density altitude to keep the engine from four-stroking if it’s tuned for standard conditions. Most external governors like the GV-1 will have problems with this, varying headspeed by as much as 20 rpm and that will cause your tail jerking and inability to track heading.

On all my gassers I have a lever on the high-speed mixture screw with a micro-servo to adjust the mixture on-the-fly with a knob on Channel 10. I’ll usually run them at full rich for startup, takeoff, landing. But in flight I lean it until I see excessive engine temp rise (approaching 200F), then richen it just enough to keep the engine temp around 165-180F. The engine temp sensor is mounted on the block by the exhaust port.

Dear Chris,

Thanks for the input. Actually I have changed the servo and made some maintenance on the tail gear plus changed the dead zone. So now it is back to normal flying form. Honestly helicopter is flying quite well no issues at all. I also changed back to H_RSC mode back to 3 as I was checking if that mode 2 will make a difference.

I was testing the land earlier and I saw a bouncing attitude one the skid touches the ground. At that time I immediately put the idle down and doesn’t let the ardupilot continue the landing procedure. Today I actually let the autopilot complete landing procedure.

Not sure why this is happening as I didn’t have such reaction on the electric one but that one ardu version was 3.5.7.

I increased the LAND COL MIN to 125 to see if it reduce the bounce but no help. I also changed the PILOT THR BHVR to 4 and no change as well.

Attached is the video of the bounce flight.

for some reason I cannot upload the video link I can email if needed

and the log file

has anyone had similar issue during landing?


Well, there is a ground effect compensation setting that some have reported helps with the bounce. I have never personally tried it. I have had bad results from letting the autopilot land expensive helicopters**. So I don’t use any sort of altitude controlled mode for landing or takeoff as my pilot skills far exceed the capabilities of the autopilot.

So I guess I would enable that ground effect comp setting and see if it makes a difference.

By all means get that back to throttle curve. With a piston engine you are out of luck without a throttle curve if anything fails in the governor. And these governors read the throttle curve for feedforward and they will “hunt” if it’s not present and cause tail jerking problems. Been there, done that, with the GV-1 and aerospire.

**I will comment on this in case it sounds like the autopilot can’t land one. It can. Just that I don’t personally trust it. Most days when I’m flying the wind is 12-15kts, the places I fly from are never level. The autopilot does not know how to nose the helicopter into the wind or handle slope procedure. All it takes is one $1,200 dynamic rollover to decide it’s not an exceedingly good idea.