Weird Throttle issue

So i build a quadcopter with multiwii, it was flying great, full of power lifting almost 1,8kg . But i wanted more stability and advanced features like loiter and better althold so i bought a APM 2.6. Plugged everything the right way, checked more than 5 times (not kidding), calibrated the mag, the acc, the escs and rc. Then i tuned just a touch up the gains so i could test it.
The problem started at this part. Again with everything calibrated and setup i armed my quad an tried to lift, it went a feet or two out of the ground and then few down again, my throttle was at 100%. Then i recalibrated everything and the problem did not dissapered. I tried to tweak the throttle acc PID and nothing.
Just to be sure it was not an esc problem i mounted the multiwii again, ran the megapirateng firmware without gps and compas, and it flew full throttle, it is so weird that the multiwii with megapirate is sending full throttle and the apm 2.6 is not
I’m running out of ideas, really don’t know what to do from here. It seems that the apm is only sending half throttle to the motors dont know why.

My build:

4x EMAX MT2216
Frame generic chineese dead cat
battery nano-tech 3300 25-50c
ebay gimbal

How about providing either tlogs and/or data flash logs to help troubleshoot your issue.

here it is


Ok, you need to turn up your logging as it’s set to low. Can’t see what’s going on with the log provided.

Try to set it to Nearly all if possible for testing. Then set it back down as this is a performance thing with APM. … OG_BITMASK


new log

What was your hover throttle previously on the multiwii?
I had the same issue when i started the hobby turns out my craft was under powered, which i solved with a 4s battery, i think this is due to how multiwii applies power to the motors compared to apm, in your logs it seems as tho rcout (motors) are being told to do as they should. If you are sure everything is setup correctly props and motor direction and orientation, i would look at trying a battery with a higher cell count providing your other hardware can cope with more voltage.

my hover throttle on multiwii was about 65% and had a good punch, it could climb very fast, i really don’t think my quad is under powered, also when i switched to apm i did a weight reduction of 300g. Isn’t the problem a software issue then?

Witch is strange, since i ran megapirang on the multiwii board just to test, and i did not had the throttle issues, but i also didn’t had althold since some weird baro problem and i could not get the gps to work.

Yeah, there’s not a lot to say. Your throttles are pegged.

However, you’re not getting all you can out of it. You have a lot of divergence on the ESC outputs. Ch2 is pegged, and Ch3 is only at about 1500. Not sure what the cause of this is, but Arducopter is responding to some kind of imbalance in the system. ESC"s not calibrated. Bent motor mounts, something.

could it be vibrations?

No, they actually look pretty good.

Well the esc’s are calibrated, what kind of bent motor mounts are we talking? Other question, what is the algorithm behind the throttle output?

I think i found the problem. I installed back the multiwii pro board, and it cant lift too, the esc’s must be almost dead, gonna buy new ones and post results here

Problem fixed,

So when i was screwing the motor to the arm is screwed to much and the screw broke one of the motor fases.
I got a new motor and now it flies perfectly

such a dumb mistake hahah

thanks for all support