Weird failsafe in manual issue

when i plug in in manual mode, it’ll go to failsafe. But if i switch to fbw or stabalize and then back to manual, all is good.

i thought i was having an issue with the 3.2.3 firmware, but i downgraded 3.1.1 and am still having the same issue.

I’m using a frsky taranis with L9R rx with a sbus to ppm converter into the apm. I replicated the issue with d8r-xp rx in ppm mode. I’m also using elevon mixing.

attached are are the logs from this morning on the bench from the 3.2.3 and the 3.1.1 firmwares.

thank you for the help.

make your TX output something below 2000µs and 1760µs as manual, (just a wild guess… )

i thought i posted this morning.

i think it’s a rc calibration problem b/c i was calibrating with my radio too close to my rx.

i have some more bench testing to do, but i think everything is cool.

logs are very useful.

i recal’d and haven’t been able to reproduce yet.

if you don’t have battery/throttle/ or gcs failsafe enabled, how would failsafe be triggered?

i do have rssi enabled, would rssi going to zero cause a failsafe?

thanks for the help.

Do you have the RSSI from the L9R hooked into the pixhawk?

yes, into apm

it works, i’ll unplug it to try.