Waypoint radius using RTK

I have finally got my GPS RTK to work. I get better than 6 decimal point lat/lon so I estimate my positioning error is somewhere in the order of 20 to 50cm. I had lot of difficulty in following the waypoint path accurately with a lot of meandering but by setting the NAV1_PERIOD down to 2 and NAV_DAMPING to 1.0 I get it to follow fairly well. I sometimes get circling around a waypoint and was curious if anyone had ideas about what the waypoint radius should be. If I enter 0.1 in the adv param, I read it back as 0 ! Also, what is the waypoint accuracy in MP waypoint files ?

I have done all this in 2.50 pixhawk and I plan to try 3.0 in the next few days. Great to hear that ardurover/pixhawk has support.

Imagine that when the rover heads for a new waypoint it draws a line 90 degress to its current path through the waypoint. When it crosses that line AND is within WAYPOINT_RADIUS the waypoint is deemed as being reached. Does that help?

I think you will find your rover navigates better when you upgrade to 3.0.1.

Thanks, Grant.

That is useful. I have now installed 3.0.1. I am using the RKite GPS from North. They were kind enough to modify ardurover 3.0 for theri RTK GPS. It is little expensive but it works quite well. It is at
https://github.com/jaluna/ardupilot. Maybe you could incorporate it as an option in the standard firmware build.
I have never go an answer for the accuracy of the waypoint coords stored in MP. Do you know ?

In 3.0 I am having some difficulty getting the compass to agree with known magnetic headings. Is there a way to adjust this ? I seem to be off by 30 deg or so. Otherwise I will see if I can get better nav with 3.0


Be great if they could raise a pull request with their changes for the ArduPilot master branch.
When you say accuracy of the waypoints stored what do you mean? They are a communicated as floats between ardupilot and the GCS. It works out they contain an accuracy of roughly 1m depending where you are in the world.
Have you run compass cal? There is a new onboard mag cal - give that a go.
Thanks, Grant.

I will ask them to do that. Let me clarify my question about waypoint accuracy. Say in LEARN mode I set the waypoints by moving the rover to various points along the path and use CH7 toggle. With RTK the lat/lon accuracy of these point is ±20cm or better so if I now run the course in AUTO it should hit these points (within the waypoint radius which is set to 0.2). Correct ? Now I read the waypoints into MP and save them to a file. When I load this mission back in the future into MP and then write to the pixhawk will I retain this accuracy of the waypoints or is it rounded off to the nearest 1 M ? Or is it 0.1m (6decimals lat/lon)? That’s the question.
I could not do live compass cal in 3.0 (MP1.38) - I never got any white squares but I will try again. Got Compass variance errors but I usually ignore these along with bad AHRS messages. No idea how to use the onboard mag cal and could not find any documentation about it…Thanks.

Stiil Rover troubles ! The RTK is working great. I got the NorthGPS changes into 3.0.1 so I am using this version. I set up a rectangular course about 50m x100m. The rover gets to each waypoint and I was getting better and better path following by changing NAV1_PERIOD ( now down to 2.0). NAV1_DAMPING helps weaving and I was at the maximum recommended limit of 1.0. Waypoint radius is set to 0.1 and changing it to 0.5 does not seem to make any difference. After two successful runs, suddenly, I get a lot of weaving between waypoints with abrupt direction changes. It gets to the waypoints but in a drunken manner manner with some 360 circles. No parameters were changed. OK. So I load my previous good configuration ( I save every trial run) and I get the same erratic behavior but these parameters worked fine 10 minutes ago on the same course. The drive hardware seems to be fine and it drives as expected in Manual. I do notice that the compass seems to point in different directions when I return the rover to a known position and heading.

Do you think the compass is malfuntioning ? I assume it is important in this slow speed application. I did notice that if turn EKF2 off then the rover just goes all over the place. Compass was ok in live calibration. Seems to be off by 25 deg or so but I know no way to correct this.I tried the onboard cal but nothing happens when I hit the start button.

This is the second time the same thing has happened (last was with 3.0.0). It will do 3 or 4 circuits of the course fairly well and then it starts to just go haywire.

Any insights appreciated - starting to tear my hair out.

I need ONE logfile - .BIN dataflash log please of when the issue occurs. However, if the software and parameters haven’t changed and it starts occurring sounds like a hardware problem. I bet its linked to your RTK GPS - that’s just an educated guess.
Thanks, Grant.

Spent some time going over all the rover parameters. Retuned everything using 3.0.1. The rover now works like a charm. Follows perfectly. The North RTK GPS takes a 10 minutes or so to get a good RTK fix but tracking accuracy is better than 10 cm. Kinda of neat watching a 2000 lb tracked vehicle going around the course. I took a video of the rover going around the test course with me standing inside it but the video is too big to upload. I will have someone edit and upload a version in next few days. Thanks Grant !

That’s great news its working. Upload the video to dropbox or equivalent and put a link in here so we can all see it! Looking forward to it.
Thanks, Grant.