VL53L1X distance offset

On my indoor 3" copter I am using VL53L1X Rangefinder and Thone Flow board for positioning. I was wondering why I can’t take off in Pos Hold or Loiter mode as I get the message “need position estimate”. The reason for this message is that the rangefinder is not showing distance values when the drone is standing on ground. The VL53L1X is working from 4cm on. Distance from ground to sensor is 5cm when the drone is standing on ground. If I lift the drone manually I get the first value (1cm) when the real distance to ground is already 13cm. The same sensor board, connected to an arduino uno with a common Vl53L1X script running reads around 5cm from the onboard position on the drone. So my question is why do I get false reading in Mission Planner and is there a solution for this problem? I don_t want to set the small drone on 13cm long legs.

Have you already set this parameter?

  • RNGFND1_GNDCLEAR = 10 or more accurately the distance in cm from the range finder to the ground when the vehicle is landed. This value depends on how you have mounted the rangefinder.

I have set RNGFND1_GNDCLEAR = 5!

I have also tested with 10 and 13cm but the result is still the same. It seems that RNGDND1_GNDCLEAR has no influence on the distance values.

Does anyone know a solution regarding the distance offset? Also what is the ground clear parameter good for if it is not working?

Today I tried to visualize the issue with height measurement. I brought 2 VL53L1X boards to a height of 13cm. One board is running on my drone with firmware 4.3.2, connected to Mission Planner and the other sensor runs with an Arduino script. The Sensor on my drone shows 1cm, the one with Arduino shows 9,5cm. So adding 4cm at which the sensor starts working gives us the real height of 13,5cm. The sensor on my drone gives only 5cm so there is a delta of 8cm. What is the reason for this and how can I solve this problem to be able to take off in loiter mode?

Just tested this morning, confirm 8cm error
BTW I tested with VL53L0x and it report distance correctly

I suggest you open an Issue on github

Thank’s for your test and the confirmation of my measurement data. I have opened an issue on github.

1 Like