Servers by jDrones

Video with tuning advice for throttle/speed control

tuning
rover

(rmackay9) #1

I made this video a few days ago to give some advice on tuning the throttle/speed control. I’ve also linked it to the bottom of the Tuning Speed and Throttle wiki page.


(RoboBill) #2

Great video. Nice to see some “this is what to expect” on the graphs. As for the braking, how does one know that the braking will not damage the controller?

RoboBill


(rmackay9) #3

@RoboBill,

Txs! My guess is that turning on braking is always safe. I think some ESCs (aka motor driver boards) come with a default setting that requires the driver to pause at neutral before applying reverse but I suspect this is to make it less likely that the driver accidentally backs up the vehicle when trying to slow down. I’m not really sure.

At some point we may just default the brake to ON.


(RoboBill) #4

@rmackay9

My only concern with braking was whether or not the motor driver could handle the surge generated by the motors. According to my drivers website, https://www.dimensionengineering.com/products/sabertooth2x60 it sounds like it can; “Sabertooth also allows you to make very fast stops and reverses”.

RoboBill


(Michael ) #5

thx for this video. i really hope to see video for pid tuning for boats :sweat_smile: or auto pid tunning option for boats. You guys are really nice people for doing all this hard work. sorry for my bad english


(rmackay9) #6

Michael,

Yes, a boat tuning video is on the list as well. txs!


(Ru) #7

Hi rmackay,
your video is very helpfull but I have some problems with the cruise learning procedure.
I tried to set the cruise_speed and the cruise throttle with the same steps as your video, but I received the following messages from the mission planner:
1- CRUISE LEARNING STARTED (rover in motion with manual flight mode and ch7 lever DOWN);
2- CRUISE LEARNING FAILED (rover in motion with manual flight mode and ch7 lever UP).
Why my procedure fails?
I need to set a max speed and a max acceleration to a lower values than the top speed and top acceleration. This because I noticed that using the rover in manual mode at top speed it disconnect the alimentation.
thanks


(rmackay9) #8

Hi Ru,

The learning should only fail if the throttle is below 10% or over 100% (which shouldn’t be possible) or the vehicle is moving backwards. These are the only times it should fail…

If you have a dataflash log I could have a look…


(Ru) #9

I HAVE SOME PROBLEM WITH THE DATAFLASH LOG. I RECEIVE THIS ERROR


(rmackay9) #10

Ru,

make sure the vehicle is disarmed before you try to download the logs…


(Ru) #11

I send you the dataflash log of today failed cruise learning procedure

FILE .LOG - ( https://drive.google.com/open?id=123wcE8QfSdnYt6kewxOnO24txDKWYARs )

FILE .BIN - (https://drive.google.com/open?id=1zxxU7dEfbHUQB5sK-vWWe6gKVzDwNH1w )

thamks for the attention